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Notice
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Mandatory Customer Information

Warranty
Avaya Inc. provides a limited warranty on this product. Refer to the "Limited Use Software License 
Agreement" or other applicable documentation provided with your package to establish the terms of the 
limited warranty.

Preventing Toll Fraud
Toll Fraud is the unauthorized use of your telecommunications system by an unauthorized party (for 
example, a person who is not a corporate employee, agent, subcontractor, or working on your company’s 
behalf). Be aware that there is a risk of toll fraud associated with your system and that, if toll fraud occurs, 
it can result in substantial additional charges for your telecommunications services.

Avaya Fraud Intervention
If you suspect that you are being victimized by toll fraud and you need technical assistance or support, call 
the Technical Service Center’s Toll Fraud Intervention Hotline at 1-800-643-2353.

Providing Telecommunications Security
Telecommunications security of voice, data, and/or video communications is the prevention of any type of 
intrusion to, that is, either unauthorized or malicious access to or use of, your company’s 
telecommunications equipment by some party.

Your company’s “telecommunications equipment” includes both this Avaya product and any other voice/
data/video equipment that could be accessed via this Avaya product (that is, “networked equipment”). 
An “outside party” is anyone who is not a corporate employee, agent, subcontractor, or working on your 
company’s behalf. Whereas, a “malicious party” is Anyone, including someone who may be otherwise 
authorized, who accesses your telecommunications equipment with either malicious or mischievous intent.
Such intrusions may be either to/through synchronous (time multiplexed and/or circuit-based) or 
asynchronous (character-, message-, or packet-based) equipment or interfaces for reasons of:
• Utilization (of capabilities special to the accessed equipment)
• Theft (such as, of intellectual property, financial assets, or toll-facility access)
• Eavesdropping (privacy invasions to humans)
• Mischief (troubling, but apparently innocuous, tampering)
• Harm (such as harmful tampering, data loss or alteration, regardless of motive or intent)
Be aware that there may be a risk of unauthorized or malicious intrusions associated with your system and/
or its networked equipment. Also realize that, if such an intrusion should occur, it could result in a variety 
of losses to your company, including but not limited to, human/data privacy, intellectual property, material 
assets, financial resources, labor costs, and/or legal costs.

Your Responsibility for Your Company’s Telecommunications Security
The final responsibility for securing both this system and its networked equipment rests with you - an Avaya 
customer’s system administrator, your telecommunications peers, and your managers. Base the fulfillment 
of your responsibility on acquired knowledge and resources from a variety of sources including but not 
limited to:

• Installation documents
• System administration documents
• Security documents
• Hardware-/software-based security tools
• Shared information between you and your peers
• Telecommunications security experts

To prevent intrusions to your telecommunications equipment, you and your peers should carefully program 
and configure your:

• Avaya provided telecommunications system and their interfaces
• Avaya provided software applications, as well as their underlying hardware/software platforms and 
interfaces
• Any other equipment networked to your Avaya products
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Part 15: Class A Statement. This equipment has been tested and found to comply with the limits for a Class 
A digital device, pursuant to Part 15 of the FCC Rules. These limits are designed to provide reasonable 
protection against harmful interference when the equipment is operated in a commercial environment. This 
equipment generates, uses, and can radiate radio-frequency energy and, if not installed and used in 
accordance with the instructions, may cause harmful interference to radio communications. Operation of this 
equipment in a residential area is likely to cause harmful interference, in which case the user will be required 
to correct the interference at his own expense.
Part 68: Network Registration Number. This equipment is registered with the FCC in accordance with 
Part 68 of the FCC Rules. It is identified by FCC registration number AV1USA-28011-MA-T. Refer to 
“Federal Communications Commission Statement” in “About This Book” for more information regarding 
Part 68.

Canadian Department of Communications (DOC) Interference Information
This digital apparatus does not exceed the Class A limits for radio noise emissions set out in the radio 
interference regulations of the Canadian Department of Communications.

Le Présent Appareil Nomérique n’émet pas de bruits radioélectriques dépassant les limites applicables aux 
appareils numériques de la class A préscrites dans le reglement sur le brouillage radioélectrique édicté par 
le ministére des Communications du Canada.

Trademarks
Avaya Predictive Dialing System and Avaya PDS Internet Monitor is a 
trademark of Avaya Inc. 

Microsoft Internet Explorer and Windows 2000 is a trademark of Microsoft 
Corporation.

Crystal Reports is a trademark of Crystal Decisions and/or Seagate Technology Inc. 

Oracle is a trademark of Oracle Corp.

All trademarks identified by the ® or TM are registered trademarks or trademarks, respectively, of Avaya 
Inc. All other trademarks are the property of their respective owners. 
Ordering Information
Call: Avaya Publications Center

Voice 1-800-457-1235 International Voice 410-568-3680

Fax 1-800-457-1764 International Fax 410-891-0207

Write: Avaya Publications Center

2855 North Franklin Road

Indianapolis, IN 46219 

If applicable, refer to the section in "About this Book" entitled "Related Documents."

For information about Avaya products and services, go to www.avaya.com.

For support on Avaya products, go to support.avaya.com.

For online updates to this documentation and product documentation for all Avaya products, go to 
support.avaya.com and click on Product Documentation.

For information about Avaya product training, go to www.learning-avaya.com.

European Union Declaration of Conformity

The “CE” mark affixed to the DEFINITY ONE equipment described in this book indicates that the 
equipment conforms to the following European Union (EU) Directives:

• Electromagnetic Compatibility (89/336/EEC)
Low Voltage (73/23/EEC)

• Telecommunications Terminal Equipment (TTE) i-CTR3 BRI and i-CTR4 PRI
For more information on standards compliance, contact your local distributor.
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About this information product
............................................................................................................................................................................................................................................................

Purpose The purpose of this guide is to provide detailed information about 
Administration Manager 3.0.

Intended audience The audience for this manual includes customers, integration 
consultants, and application consultants.

Changes The following provides information that has changed for 
Administration Manager 3.0 This information should be used in 
reference to the AvayaTM Predictive Dialing System (PDS) version 
12.0 Service Pack 1 release.

What’s new in this release
Administration Manager 3.0 User’s Guide changed as follows:
• This User’s Guide has been branded to reflect the product name 

change from Producer to Administration Manager 3.0.
• A separate login to protect the list configuration area. Please 

contact your Customer Support Engineer for access.
• A new upload definition for removing duplicates has been added.
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1 Administration Manager 
overview
............................................................................................................................................................................................................................................................

............................................................................................................................................................................................................................................................
Overview

Purpose Administration ManagerTM 3.0 is an AvayaTM Predictive Dialing 
System (PDS) configuration tool which enables you customize your 
Avaya PDS. Administration Manager works in conjunction with the 
Avaya PDS and Campaign Director to make your system responsive to 
your changing needs.

Contents This section contains the following topic:
• Administration Manager
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Administration Manager

Overview Administration Manager allows you to:
• Add or edit completion codes
• Change agent key assignments
• Specify processing schedules
• Create, edit, and record voice messages
• Change download, calling list, and upload settings
Administration Manager lets you choose and change settings, then 
transfer those settings to the Avaya PDS using an Install Data feature. 
Once you run the Install Data feature, the changes are transferred to 
“holding” area until the next Avaya PDS reboot. After the Avaya PDS 
reboot, use the Empty Install Data feature to make your changes “live” 
on the Avaya PDS.
To prevent loss of data and operational problems, you should update 
Avaya PDS files with Administration Manager files only if the 
databases are the same (in sync). To ensure that the Administration 
Manager database and the Avaya PDS are in sync, Administration 
Manager performs a data synchronization query.

Caution
If Administration Manager displays a message that your files are out of 
sync, contact your Avaya PDS vendor to determine which files have 
changed. Your vendor will tell you how to update your files. If you do 
not follow this procedure, Administration Manager may overwrite your 
Avaya PDS files with outdated information.

System setup The Administration Manager database contains the configuration 
information required for your Avaya PDS. The Avaya PDS Integration 
Consultant selects a system’s features from various lists in 
Administration Manager. Administration Manager stores the selections 
in tables.
The information the Avaya PDS Integration Consultant defines during 
system setup includes:
• Avaya PDS number (used to identify the system you want to 

configure)
• Company name, address, and contact information
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• Products (for example, Campaign Director, Agent API) and 
features (for example, Record Edit or Managed Dialing) installed 
on the system

• System configuration information (for example, agent and 
supervisor licenses, workstation software, phone lines, host 
application, and ACD type)

• Network information for system components (for example, TCP/
IP address, component name, and alias)

• Time zone information
This data defines which Administration Manager and system features 
are available. When the settings are completed, the Integration 
Consultant connects Administration Manager to the Avaya PDS and 
uses the Install Data feature to transfer the configuration to the system.

Shared database If you have more than one Administration Manager installed to 
configure the same Avaya PDS, you have a shared database. 
Administration Manager supports a shared database environment in 
which two or more Administration Manager workstations connect to 
one common Administration Manager database. To start the 
Administration Manager database, log onto the database machine 
(server) as Administrator. For security purposes, the Administrator can 
log out of the server, leaving the database running. To run 
Administration Manager, log onto the server or any Administration 
Manager workstation as dsi.

Note
In a shared database environment, Administration Manager displays a 
warning when you try to open a file that another person is using. You 
can override the warning, but doing so can compromise data integrity.

System configuration After the installer completes the system setup, you and the installer 
review the system configuration. The configuration applies to a specific 
system and influences all applications on that system.
System configuration includes the following tasks:
• Assigning call completion codes
• Defining agent keys
• Describing messages
• Assigning messages to wait queues
• Recording messages
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• Setting up file transfers
• Scheduling processes

Application definition In Administration Manager, an application consists of is a calling list 
and its associated files, such as download and upload definitions.
Application definition includes the following tasks:
• Defining download and upload fields
• Defining file structure and transfer method
• Defining outbound calling lists and inbound lists

Important tips Use the following guidelines when working with Administration 
Manager:
• Remember to perform a system backup, including calling lists, 

prior to making any changes with Administration Manager.
• Make only one change at a time. For example, create/change 

messages, then perform Install Data. If this change occurs without 
problems after the nightly reboot, you can perform other changes 
the next day, and so on. This makes it easier to troubleshoot 
should problems occur.

• If you performed an Install Data to transfer files to the Avaya PDS 
from Administration Manager, remember to perform an “Empty” 
Install Data following the reboot of your Avaya PDS. If your 
email program contains a calendar feature, use it to set a reminder 
for yourself.
1 - 4
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Data
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............................................................................................................................................................................................................................................................
Overview

Purpose Administration Manager uses the Install data and Empty install data 
features move file changes from Administration Manager to the 
AvayaTM Predictive Dialing System (PDS).

Contents This section contains the following topics:
• Status codes
• Install Data
• Perform Install Data
• Perform “Empty” Install Data
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Status codes

Status codes All Administration Manager files have an assigned status code: In 
Process, Complete, Pending, or Live. Status codes help both you and 
Administration Manager keep track of configuration changes. The 
following table describes how each status code is used.

Data synchronization During data synchronization, Administration Manager compares the 
date and time stamps of the active Avaya PDS files with the date and 
time of the last synchronization. This determines whether any Avaya 
PDS files have changed since they were last synchronized with your 
Administration Manager database.
If data is in synch, no further action is required until the next Avaya 
PDS reboot. Administration Manager exports your selected files to a 
“pending updates” directory on the system. Administration Manager 
file statuses are changed to Pending. The pending updates are installed 
as the active configuration when the Avaya PDS reboots and you 
perform an Empty Data Install.

In Process You assign this status when you save a file but are not 
ready to transfer the file to the Avaya PDS. 
Administration Manager assigns this status to files 
copied when you use the Application Copy 
command.

Complete You assign this status when you save a file and want 
Administration Manager to automatically select the 
file for transfer in the Export dialog box. 
Administration Manager assigns this status to files 
when an Install Data transfer was unsuccessful.

Pending Administration Manager assigns this status to files 
transferred to the Avaya PDS. After the next system 
reboot, Administration Manager changes the status of 
Pending files to Live if the transfer was successful or 
Complete if the transfer was unsuccessful.

Live Administration Manager assigns this status to files 
that have been successfully transferred to the Avaya 
PDS.
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Out of synch conditions Out of synch situations may occur if your Avaya PDS vendor has made 
changes to the files on the Avaya PDS. If data is out of synch, a pop-up 
notification message appears. Administration Manager copies the 
active system files, overwriting Administration Manager’s Live data 
with the new information. 
Contact your Avaya PDS vendor to determine which files have 
changed. Your vendor will tell you how to update your files. If you do 
not follow this procedure, Administration Manager may overwrite your 
Avaya PDS files with outdated information. 
After you make the necessary changes to match your Administration 
Manager data to the current system data, set the status to Complete and 
run the Install Data command again. This exports your corrections to a 
pending updates directory on the Avaya PDS. The corrected files are 
installed after the next system reboot and “Empty” Install Data. 
Administration Manager file statuses are changed to Pending.

Verifying data
synchronization

Following the reboot, perform an “empty” install by running the Install 
Data command without selecting any files in the Export dialog box 
(clear any pre-selected files). This updates the Administration Manager 
database to show whether the new files are successfully installed on the 
system. 
If there were no errors during the installation, the Pending 
Administration Manager files become the new Administration Manager 
Live files. If a critical error was encountered, the Pending 
Administration Manager files return to the Complete status, and the 
Avaya PDS data remains unchanged.

Note
It is recommended that you not edit Administration Manager files 
while files with a Pending status exist. Run an empty install, then edit 
files with Live or Complete statuses.

Using Install Data When you select Install Data from the Data menu, the Export dialog 
box displays each file with a Complete or In Process status.

Caution
In a shared database environment, changes made to Administration 
Manager files after you select the Install Data menu option can cause 
unexpected results or data corruption. Do not change Administration 
Manager files until the export completes. Coordinate with other 
Administration Manager users before running the Install Data 
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command. Also, run the Install Data command for only one Avaya PDS 
at a time.
The following illustration describes the Install Data and Empty Install 
Data flow:
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............................................................................................................................................................................................................................................................
Install Data

Install Data When you enter or update information in Administration Manager, use 
the Install Data feature to transfer the information to the Avaya PDS.
The Install Data process performs three functions:
• Updates the Administration Manager database with the results of 

the last set of files exported to the Avaya PDS.
If the files were installed successfully as an active configuration 
on the Avaya PDS, the statuses of the exported files are changed 
from Pending to Live. If the files could not be installed, the 
statuses are changed from Pending to Complete. For more 
information about file statuses, see Status codes.

• Performs data synchronization.
Data synchronization ensures that the Avaya PDS files have not 
been changed manually.

• Exports configuration changes to the Avaya PDS.When you select 
the Install Data command, Administration Manager displays the 
Export dialog box. Administration Manager automatically selects 
files with a Complete status for export to the system. You can clear 
Complete files from the transfer list and select In Process files for 
transfer.
2 - 9



Install Data and Empty Install Data
...........................................................................................................................................................................................................................................................
2 - 1 0



Install Data and Empty Install Data
............................................................................................................................................................................................................................................................
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Perform Install Data 

Perform Install Data Use the following procedure to perform an Install Data.

...........................................................................................................................................................................

1 Select Data > Install Data.

...........................................................................................................................................................................

2 Select the system. Administration Manager displays a Processing 
System Initialization message box and then displays the install tree. 
The install tree lists all of the files with a Complete or In Process status.

...........................................................................................................................................................................

3 Select additional In Process files or clear Complete files by selecting 
the file name.

...........................................................................................................................................................................

4 Click OK. Administration Manager displays the Export confirmation 
dialog box.

...........................................................................................................................................................................

5 Click Yes.
Administration Manager notifies you that it will now update the status 
of the last files sent to the Avaya PDS.

...........................................................................................................................................................................

6 Click OK. If Administration Manager and the Avaya PDS are not in 
synch, a dialog box notifies you. Go to step 7. If there are no errors, a 
dialog box notifies you that synchronization is complete. Go to step 8.

...........................................................................................................................................................................

7 Click OK, but do not continue with export. Stop and either contact your 
Avaya PDS vendor or research the data to determine which elements 
have changed since the last data synchronization. 
When there is a data synchronization error, Administration Manager 
overwrites the Live data with the active Avaya PDS information.

...........................................................................................................................................................................

8 Click OK.
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...........................................................................................................................................................................

9 The Beginning Export dialog box appears. Click OK. 
Administration Manager exports your selected files to the “pending 
updates” directory on the Avaya PDS.

...........................................................................................................................................................................

10 An Export confirmation dialog box appears.Click OK. 

...........................................................................................................................................................................

11 After the next system reboot, run an “empty” Install Data (see Perform 
Empty Install Data)
Administration Manager updates its Pending statuses to Live for each 
file that was successfully transferred during the last Install Data. If the 
transfer was unsuccessful, Administration Manager changes Pending 
statuses to Complete.
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............................................................................................................................................................................................................................................................
Perform “Empty” Install Data

Perform “Empty” Install
Data

Use the following procedure to perform an “Empty” Install Data.

...........................................................................................................................................................................

1 Select Data > Install Data.

...........................................................................................................................................................................

2 Select the system. Administration Manager displays a Processing 
System Initialization message box and then displays the install tree. 
The install tree lists all of the files with a Complete or In Process status.

...........................................................................................................................................................................

3 Right-click with your cursor inside the main pane of the Export window 
and select Deselect > All, and then click OK. The Export confirmation 
dialog box appears.

...........................................................................................................................................................................

4 Click Yes when asked Install the files on the Avaya PDS?.
Administration Manager notifies you that it will now update the status 
of the last files sent to the Avaya PDS.

...........................................................................................................................................................................

5 Click OK to continue past the dialog box stating Previous update to the 
Avaya PDS must be processed first.

...........................................................................................................................................................................

6 Click OK to continue past the dialog box stating Database will now be 
synchronized with the Avaya PDS.

...........................................................................................................................................................................

7 Click OK to continue past the dialog box stating The database is not 
synchronized with the Avaya PDS. The database will now be 
synchronized to reflect Avaya PDS settings. Check current edits for 
this system after the process completes. The Synchronize and Import 
Status dialog box appears.

...........................................................................................................................................................................

8 Click OK after The synchronization is complete.
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...........................................................................................................................................................................

9 Click OK to continue past the dialog box stating Previous updates and 
synchronization are complete. Beginning export.

...........................................................................................................................................................................

10 Click NO to continue past the dialog box asking Send Cool Edit 
Message?

...........................................................................................................................................................................

11 Click OK to continue past the dialog box stating There was nothing to 
export. Install cancelled. This indicated the “Empty Install Data was 
performed correctly.

You will receive a dialog box stating REMINDER: It is recommended 
that you make backups of your Avaya PDS on a regular basis. 

...........................................................................................................................................................................

12 Click OK to complete the “Empty” Install Data process.
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............................................................................................................................................................................................................................................................
Overview

Purpose When a customer answers a phone call, the system transfers the call to 
an agent. At the end of the call, the agent records the outcome. The 
AvayaTM Predictive Dialing System stores the result as a completion 
code. If the Avaya PDS does not pass the call to an agent, the Avaya 
PDS generates the completion code.
The Avaya PDS uses completion codes to select records for calling and 
reports. The Avaya PDS identifies completion codes by a code number, 
call result, and description. The call result is a short name that makes 
the code easier for agents to identify. The description is a more 
detailed. Each Avaya PDS has one set of completion codes.

Contents This section contains the following topics:
• Completion codes
• Completion codes available for agent keys
• Add a completion code
• Edit a completion code
• Delete a completion code
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............................................................................................................................................................................................................................................................
Completion codes

Completion code terms System codes  System codes are defined by the Avaya PDS. You 
cannot change their description, call result, or code number. You can 
change the Allow Retries setting, which allows the you to use 
Campaign Director to set up automatic recalls. Some system codes are 
assigned to calls by the Avaya PDS. For example, BUSY or 
NOANSWER. These codes appear in the completion code list with an 
asterisk before their descriptions. A few system codes are available for 
use by agents. 

Agent codes  Agent codes are the completion codes that agents use 
during calling activities. The Avaya PDS includes some predefined 
agent codes that appear in the completion code list without an asterisk 
before their descriptions. You cannot change their description, call 
result, or code number. However, you can change the Allow Retries 
setting.
Vendors use Administration Manager to define the agent codes during 
the planning phase of your Avaya PDS. You can use Administration 
Manager to add or edit codes after setup.

Planning When you need to create or modify completion codes, consider the 
following questions before using Administration Manager:
• What types of agent call activity do you want to track (for 

example, successful sales, promises to pay, messages left)?
• What kinds of completion codes will agents use during a job?
• How do you want to select records for calling?
• What kinds of call result information do you want to include in 

reports?
• How will you set up your numbering scheme for completion 

codes?
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Example
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............................................................................................................................................................................................................................................................
Completion codes available for agent keys

Completion codes The following table lists the completion codes that you can assign to 
agent keys.

Code Call result Definition

16 RINGING Ringing phone (passed to agent). 
This is a predefined system code that 
cannot be edited but may be assigned 
to an agent key.

17 CUSTHU Customer hung up in queue. This is a 
predefined system code that cannot 
be edited but may be assigned to an 
agent key.

18 TRANSFER Transfer release. This is a predefined 
agent code that can be edited and 
assigned to an agent key.

19 RECALL Recall release. This is a predefined 
agent code that can be edited and 
assigned to an agent key.

20-34 AGENT 
CODES

These are unused completion codes 
that can be edited and assigned to 
agent keys.

35
89
90

CANCEL
MANAGEDA
MANAGEDB

These are predefined Managed 
Dialing codes that can be assigned to 
agent keys.

51-88 AGENT 
CODES

These are unused completion codes 
that can be edited and assigned to 
agent keys.

93
94
95

SOLD
VERIFIED
UNVERIFIED

These are predefined Sales 
Verification codes that can be 
assigned to agent keys.

98 AORECALL Agent Owned Recall. This is a 
predefined agent code that can be 
edited and assigned to an agent key.
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Next Steps To enable agents to use new completion codes, you must assign them to 
agent keys.
After you install the new completion codes on the system, you must 
make the same changes in Monitor and Analyst on each Campaign 
Director workstation.
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Add a completion code

Add a completion code Use the following procedure to add a completion code.

...........................................................................................................................................................................

1 Select System > Completion Codes.

...........................................................................................................................................................................

2 Select the system and click OK.

...........................................................................................................................................................................

3 In the Code Type area, select Agents codes.
This limits the display to only agent codes. You must select Agents 
codes to add or modify completion code results and definitions.

...........................................................................................................................................................................

4 In the Display Order area, select Number or Keyword.

...........................................................................................................................................................................

5 In the Result box, type a call result for an unused code (up to 14 
alphanumeric characters. 

...........................................................................................................................................................................

6 In the Description box, type a description.

...........................................................................................................................................................................

7 In the Allow Retries check box, select the box to indicate yes, or leave 
the box blank to indicate no. 

...........................................................................................................................................................................

8 Repeat steps 5 through 7 for each code you want to add.

...........................................................................................................................................................................

9 Select File >Save.

...........................................................................................................................................................................

10 In the Save dialog box, select In Process or Complete. If you have 
completed all your changes and want the new file transferred to the 
system, select Complete. If you are not ready to replace the files, select 
In Process.
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............................................................................................................................................................................................................................................................
Edit a completion code

Edit a completion code Use the following procedure to edit a completion code.

...........................................................................................................................................................................

1 Select System > Completion Codes.

...........................................................................................................................................................................

2 Select the system and click OK
If the system displays a Live or Pending status, Administration Manager 
displays the View or Edit dialog box. Select Edit to create a copy of the 
file.

...........................................................................................................................................................................

3 In the Code Type area, select Agents codes.
This limits the display to only agent codes. You must select Agents 
codes to add or modify completion code results and definitions.

...........................................................................................................................................................................

4 In the Display Order area, select Number or Keyword.

...........................................................................................................................................................................

5 In the Result box, type a call result for an unused code (up to 14 
alphanumeric characters.

...........................................................................................................................................................................

6 In the Description box, type a description.

...........................................................................................................................................................................

7 In the Allow Retries check box, select the box to indicate yes, or leave 
the check box blank to indicate no. 

...........................................................................................................................................................................

8 Repeat steps 5 through 7 for each code you want to edit.

...........................................................................................................................................................................

9 Select File >Save.
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...........................................................................................................................................................................

10 In the Save dialog box, select In Process or Complete. If you have 
completed all your changes and want the new file transferred to the 
system, select Complete. If you are not ready to replace the files, select 
In Process.

Note
After you define and save an Agent code, you can modify the Result, 
Description, and Allow Retries settings. If you change the Result field 
to change the meaning of the completion code (for example, from 
SALE to CALLBACK), it may affect system statistics and reports.
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............................................................................................................................................................................................................................................................
Delete a completion code

Delete a completion code Use the following procedure to delete a completion code.

...........................................................................................................................................................................

1 Select System > Completion Codes.

...........................................................................................................................................................................

2 In the Select System dialog box, select the system and click OK. 
If the system displays a Live or Pending status, Administration Manager 
displays the View or Edit dialog box.

...........................................................................................................................................................................

3 In the Code Type area, select Agents codes. 
This limits the display to only agent codes. You must select Agents 
codes to delete completion code results and definitions.

...........................................................................................................................................................................

4 In the Display Order area, select Number or Keyword.

...........................................................................................................................................................................

5 Select the completion code that you want to delete.

...........................................................................................................................................................................

6 Select Edit > Delete Row. 
Administration Manager replaces the Result and Description 
information with NOTUSED.

...........................................................................................................................................................................

7 Repeat steps 5 and 6 for each code you want to delete.

...........................................................................................................................................................................

8 Select File > Save.

...........................................................................................................................................................................

9 In the Save dialog box, select In Process or Complete. 
If you have completed all your changes and want the new file transferred 
to the system, select Complete. If you are not ready to replace the files, 
select In Process.
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Note
When you remove a completion code, Administration Manager 
automatically checks all agent keys files for that code. Administration 
Manager clears the code from each agent key file and lists the affected 
keys files. Edit the In Process or Complete copy of each listed keys 
file to assign a new completion code or clear the key.
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............................................................................................................................................................................................................................................................
Overview

Purpose Agent keys are the computer function keys that agents use to complete 
AvayaTM Predictive Dialing System (PDS) tasks. Agents use these keys 
to record the result of a call or to start an action such as playing a 
recorded message for a customer, logging off the job, or switching 
screens.

Contents This section contains the following topics:
• Agent keys
• Add an agent key
• Predefined agent key actions
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Agent keys

Overview Agent keys perform actions that are available on your system, such as 
releasing a call, transferring a call, displaying an agent screen, and 
logging an agent out of a job. See Predefined agent key actions for a list 
of predefined agent key actions.
Depending on the selected action, you can also set up agent keys to 
assign a completion code to a record, display an agent screen, or play 
an automated message to the customer.
You can design one key set that is available to all jobs, or you can have 
multiple key sets.
Use Administration Manager to add or edit keys to meet your call 
center’s changing needs. Agent keys are F1 through F12 or higher, 
depending on the type of keyboard. In addition to the function keys, 
you can assign key combinations to increase the number of available 
keys. For example, the agent can press and hold the Ctrl key or Alt key 
while pressing the function key.

Note
Your agents may have one or more keys assigned to Cut and Paste 
information. Do not use these key combinations for agent keys 
assigned in Administration Manager. The key combination Alt + F4 is 
used by Windows and cannot be changed.

Plan When you need to add or modify agent keys, consider the following 
questions before using Administration Manager:
• How many function keys are available on agent keyboards?
• What are the most frequently used completion codes or actions? 

Consider assigning these to a single function key rather than a key 
combination.

• If agents typically use more than one screen, can you designate the 
first few keys to go to a screen (for example, F2 displays screen 
2)?

• Do you need one set of keys for all jobs or multiple sets?
• Can you take advantage of any mnemonic association with a code 

and a key? (For example, Ctrl+Shift+T plays an automated 
message containing a technical tip.)
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Example
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Add an agent key

Add an agent key Use the following procedure to add an agent key.

...........................................................................................................................................................................

1 Select System > Agent Keys.

...........................................................................................................................................................................

2 Select the system and then click New.

...........................................................................................................................................................................

3 Type a name (up to 5 alphanumeric characters) and description for the 
key set and then click OK. The Avaya PDS adds the prefix ag_ to the 
file name.

...........................................................................................................................................................................

4 Select an action for the agent key from the Action list.

...........................................................................................................................................................................

5 Select a call result, screen number, or NONE in the Call Result or 
Screen Number list. 
If you selected Go To Screen in the Action box, select a screen number. 
If you selected an action that does not require a call result or screen 
number, such as Adjust ear volume, select NONE.
Some codes can be assigned to multiple keys.

...........................................................................................................................................................................

6 Select the message file in the Automated Message Assignment box if 
you want to assign this agent key to an automated message. The drop-
down list displays any messages you have assigned to Automated 
Message queues

...........................................................................................................................................................................

7 Repeat steps 4 through 6 for each agent key you want to define.

...........................................................................................................................................................................

8 When you complete the set, select File > Save.
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...........................................................................................................................................................................

9 In the Save dialog box, select In Process or Complete.
If you complete all your changes and want the new file transferred to the 
system, select Complete. If you are not ready to transfer the file to the 
system, select In Process.
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Predefined agent key actions

Predefined agent key
actions

The following table lists predefined agent key actions. Depending on 
how your system was set up, your system may not have all of these 
agent key functions available.

Action Description

Adjust ear volume Displays a dialog box used to adjust the 
ear piece volume. (See your Avaya 
PDS administrator to determine if this 
action is available on your system.)

Adjust mouth volume Displays a dialog box used to adjust the 
mouth piece volume. (See your Avaya 
PDS administrator to determine if this 
action is available on your system.)

Agent assistant key Displays a message on the system 
supervisor screen requesting assistance.

Blind trans to INB Releases the outbound call and 
associated Avaya PDS record to an 
inbound or blend job, freeing the agent 
for another call. (See your Avaya PDS 
administrator for available transfer 
methods.)

Dial pad enable Displays a dialog box with a telephone 
keypad (if VLTERM is used).

Display values Displays a list of acceptable entries for 
the selected field.

Field call Dials the phone number in the selected 
field.

Go to first editable field Moves the cursor to a predetermined 
position on the screen.

Go to screen Displays the selected screen on the 
agent’s workstation monitor. Select a 
screen in the Call Result or Screen 
Number column.
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Hookflash blind trans Transfers the call and associated Avaya 
PDS record using the hookflash method 
and frees the agent for another call. 
(See your Avaya PDS administrator for 
available transfer methods.)

Hookflash supv trans Transfers the call and associated Avaya 
PDS record using the hookflash method 
but keeps the agent on the line with the 
customer. (See your Avaya PDS 
administrator for available transfer 
methods.)

Log out of job Requests to remove the agent from the 
job (required for each key set).

Managed cancel call Releases the Managed job preview 
record without dialing.

Managed dial ahead Dials the preview record during a 
Managed job before the preview time 
expires.

Manual call Allows the agent to type a phone 
number for the system to dial.

Manual hangup Releases the customer from the phone 
line but retains the agent’s connection 
to the line to make a manual or field 
call.

Mark as Do Not Call Marks the customer’s record as Do Not 
Call for all calling lists included in the 
job’s Do Not Call group.

NOTUSED Indicates the key has no defined 
function.

Place call on hold Places the call on hold

Re-connect headset Reconnects the agent to the customer 
that he or she placed on hold.

Refresh screen Redisplays the dialog box without the 
agent’s entries.

Action Description
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Release line Codes the call and releases the 
customer connection (the record is still 
available).

Release line and record Codes the call and releases the agent’s 
connection with the customer and 
record.

Release record Releases the record, freeing the agent 
for another call.

Set recall Displays the recall appointment dialog 
box.

Supv trans to INB Transfers the outbound call and 
associated record to an inbound or 
blend job but keeps the agent on the 
line with the customer. (See your Avaya 
PDS administrator for available 
transfer methods.)

Toggle Key Switches between the host and the 
Avaya PDS sessions.

Transfer call Transfers the call and frees the agent 
for another call. (See your Avaya PDS 
administrator for available transfer 
methods.)

Trunk transfer Transfers the call using the trunk 
method but keeps the agent on the line 
with the customer. (See your Avaya 
PDS administrator for available 
transfer methods.)

Undo last change Restores the last change in the current 
text field to its previous state.

Action Description
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............................................................................................................................................................................................................................................................
Overview

Purpose Messages are the digitized recordings that customers hear when they 
are on hold, waiting for an agent, during a Virtual Agent job, or when 
an agent plays a message. Messages serve a number of functions. They 
can assure callers that their calls have not been disconnected. They can 
prepare callers for the upcoming transaction, asking them to have credit 
cards and order numbers ready. They can answer frequently asked 
questions. They can promote the business or advertise new products 
and services.

Contents This section contains the following topics:
• Message overview
• Message text types
• Create a message
• Edit a message
• Message assignments
• Create a message assignment
• Telephony.spt file
• Delete Message Assignments
• Modify one or more Message Assignments
• Recording messages
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• Message Mapping overview
• Create a message map
• Message value wildcard characters
• Select a message map
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Message overview

Messages The following illustration describes the steps in creating a message.

There are three components to creating a message: 
• Define and create message text
• Assign messages to wait queues and message scripts
• Record and digitize messages
• Message Mapping (optional)

Define and create message text
Define and create message text by assigning the message a file name, 
writing the text of a message, assigning it to a message type, and 
identifying the message as a male voice, female voice, or music. 
Although it is not mandatory to type the full text of the message, most 
companies find it helpful to have a written record of the text.

Assign messages to wait queues and scripts
Assign messages to wait queues according to how the message is going 
to be used. For example, is it an outbound or inbound wait queue, and 
do you have 1 or more messages, as in a script? Use the answers to 
assign messages to the appropriate wait queues and scripts.

Record and digitize messages
Record your messages and digitize messages to play on the Avaya 
PDS. Once created and digitized, the messages are ready to use on your 
next job.
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Message Mapping (optional feature)
This optional feature enables you to choose a specific field in each 
record on the calling list. The information in this field determines 
which message will be played to the customer.
Use Message Mapping to perform the following functions:
• Select source fields from the calling list. You can use any field that 

exists on the calling list.
• Define source values the system will compare to the data in the 

source field on the calling list. You can defined specific source 
values or a range of values. You can also use wild cards.

• Select the empty field you defined in the calling list to receive the 
message number. (The Avaya PDS places the message number 
into this field.)

• Save each message map with a specific file name. Message maps 
are stored on the dialer. A .mm extension is added to your 
filename.

For example, you can target records form specific states with unique 
messages relevant to the state, or you can play one message to an 
account holder that is 30 days past due, and a different message to an 
account holder that is 90 days past due. The following items are used 
with Message Mapping:
• Use message text to save and name messages used in message 

maps
• Use message assignments to specify the calling list field to use to 

target records during preprocessing and to specify a default 
message to play if the message map finds no relevant value in the 
calling list field that you have chosen.

• Use the calling list feature to select the Avaya PDS and the calling 
list to use when specifying message maps, select message maps, 
and save your selections. You can link a message map to more 
than one calling list.

Message numbers You can record up to 1970 messages. However, most switches limit the 
total time for all messages to 35 minutes. The digital switch uses the 
message number to access the file.
The voicemsg.cfg file on the system links each message file with a 
message number. This allows the Avaya PDS to refer to the messages 
by number rather than by file name. The message number refers to the 
file’s location on the Large Port Voice Card (LPVC).
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File names Using the Message Text menu command, you define the file name, text 
of the message, message type, and the message gender for all of your 
messages. Give each message a unique name of up to eight characters. 
The name cannot contain any special characters. Do not type an 
extension. When you record the message, Administration Manager 
adds a .AU extension. The file name identifies the sound file located on 
the system.
The following table lists examples of file names.

Plan When you need a new message, consider the following questions 
before using Administration Manager:
• What will be the text of the message? 

Many people find it helpful to write out the message. The recorded 
message and the message text should match.

• What is the purpose of the message and how will it be used?
• Will the message be recorded with a male or female voice or both?

Whenever possible, have the same person record all messages to 
be used in a series.

• Will you have to remove a message to make room for this one?

Message 
Name

Description

fwait1 First outbound wait queue message recorded using 
a female voice

mwait1 First outbound wait queue message recorded using 
a male voice

fwait2 Second outbound wait queue message (female 
voice)

mwait2 Second outbound wait queue message (male 
voice)

infwait1 First inbound wait queue message (female voice)

inmwait1 First inbound wait queue message (male voice)

fpf1 Agent key message (female voice). (pf is a 
standard designation for agent keys. It comes from 
the abbreviation for programmable function keys.)

mpf1 Agent key message (male voice)
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You are limited to 1970 digitized messages on the server.
• Could you use an existing message instead of creating a new one?
• Which queue will use the message?
• What languages do we need for these messages?

Example
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............................................................................................................................................................................................................................................................
Message text types

Message text types When you create a message, you are required to classify it into one of 
four types: Automated, Inbound, Outbound, or Universal. When 
creating your message, you use the Type list to make your selection 
based on the message’s intended use.

Automated Delivered when an agent presses a function key or 
during a Virtual Agent job

Inbound Delivered to customers when they are on hold in 
an inbound wait queue

Outbound Delivered to customers when they are on hold in 
an outbound wait queue

Universal Serves multiple purposes (available for all queue 
types)
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Create a message

Create a message Use the following procedure to create a message to play to customers. 

...........................................................................................................................................................................

1 Select System > Message Text.
The Select System dialog box appears.

...........................................................................................................................................................................

2 Select the system and then click OK.

...........................................................................................................................................................................

3 Select a type in the Display Queue Type area.
Select All if you do not want to limit the display.

...........................................................................................................................................................................

4 Select the sort order for the display in the Display Order area.

...........................................................................................................................................................................

5 Place your cursor in the File Name box of an unused message number 
and type a name for the message. Unused message numbers display 
NOTUSED.

...........................................................................................................................................................................

6 Select a message type in the Type list.

...........................................................................................................................................................................

7 Select male or female in the Music or Voice box.

...........................................................................................................................................................................

8 Double-click the Contents box to display a larger text box and then type 
the text of your recorded message.

...........................................................................................................................................................................

9 Select File > Save.

...........................................................................................................................................................................

10 In the Save dialog box, select In Process or Complete.
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If you complete all your changes and want the new file transferred to 
the Avaya PDS, select Complete. If you are not ready to transfer the 
file to the Avaya PDS, select In Process.
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Edit a message

Edit a message Use the following procedure to edit a message.

...........................................................................................................................................................................

1 Select System > Message Text.
The Select System dialog box appears.

...........................................................................................................................................................................

2 Select the system and then click OK.

...........................................................................................................................................................................

3 Edit the File Name, Type, Music or Voice, and Contents boxes.

...........................................................................................................................................................................

4 Select File > Save.

...........................................................................................................................................................................

5 In the Save dialog box, select In Process or Complete.

If you complete all your changes and want the new file transferred to 
the Avaya PDS, select Complete. If you are not ready to transfer the 
file to the Avaya PDS, select In Process.
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Message assignments

Overview After you create the message text files, use the Message Assignment 
dialog box to first assign messages to queue types and then to set up 
scripts. A script is a series of messages that customers hear in the 
inbound, outbound, or transfer wait queues. You designate the order in 
which the Avaya PDS plays the messages. You can choose to play 
music or have silence between messages. A script may also consist of a 
single message.

Message assignment
queue types

As stated earlier in Message overview, Administration Manager 
requires that you assign messages to one of four message types: 
Automated, Universal, Inbound, or Outbound.
Similar to choosing message types, the Avaya PDS also requires that 
you assign message assignments (scripts) to one of five wait queue 
types:
• Automated
• Virtual
• Transfer
• Inbound
• Outbound
The difference between the two types is that message assignment types 
are more vast—they provide a label where scripts (which consist of 
individual messages that each have their own message type) are played 
for a specific circumstance.
The following table shows how the message types and message 
assignments relate to each other.

Wait queue 
type

Description Allowable message 
types

Automated Used for messages that the 
agents play to customers 
using an agent function key

Automated Universal

Outbound Used to assign messages 
that the system plays to 
customers in outbound wait 
queues and to answering 
machines

Outbound, 
Automated, Universal
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Wait queue list On the Wait Queue dialog box, there is a Wait List Action list, which 
has four options:
• Deliver Message
• Pause
• Start Looping
• Voice Response
Note that the only wait queue action available for the Automated queue 
type is Deliver Message.

Inbound Used to assign messages 
that the system plays to 
customers in inbound wait 
queues

Inbound, Universal

Transfer Used to assign messages 
that the system plays to 
customers in transfer wait 
queues

Inbound, Universal

Virtual Used to assign messages 
that the system plays to 
customers during Virtual 
Agent jobs (jobs that 
deliver messages without 
agent intervention)

Automated, Universal

Wait queue 
type

Description Allowable message 
types

Action Description Queue type

Deliver 
Message

Plays a recorded message. 
You select the name of the 
message file. The file may 
contain voice or music.

Automated, 
Outbound, Inbound, 
Transfer, Virtual

Pause Specifies how long to wait 
between messages. You 
select the amount of delay 
(silence) in seconds.

Outbound, Inbound, 
Transfer
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Outbound wait queue
example

The following shows how messages are combined to make a script.
1. Hold the line please. I have a very important call for you from 

(company name).
2. 5 second pause.
3. Start Looping. (This loop begins with line four. The system will 

repeat all lines below the start looping statement for the length of 
time listed in Campaign Director.)

4. Sorry to keep you waiting. I’m still trying to connect.
5. 5 second pause.
6. Still trying, hold please.
7. 5 second pause.
8. Still trying to connect. Thank you for waiting.
9. 8 second pause.

Inbound wait queue
example

The following shows how messages are combined to make a script.
1. Thank you for calling (company name). A representative will be 

with you shortly.
2. 5 second pause.
3. Your call is important to us. Please hold for the next available 

representative.
4. 7 second pause.

Start 
Looping

Instructs the system to repeat 
the wait queue actions that 
follow. You must follow this 
command with a Deliver 
Message statement. Use Job 
Editor to set the maximum 
time a caller can stay in the 
queue.

Outbound, Inbound, 
Transfer

Voice 
Response

Instructs the system to wait 
for a voice response to verify 
that the caller or called party 
is still on the line. If not, the 
system disconnects the line.

Outbound, Inbound

Action Description Queue type
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5. Please continue to hold. A representative will be with you 
momentarily.

6. 7 second pause.
7. Start Looping. (This loop begins with line eight. The system will 

repeat the message and music as many times as you set in the Job 
Editor.)

8. Thank you for waiting, please continue to hold.
9. Music.

Automated message
example

This script consists of a single message that the system plays when an 
Agent presses a function key.
• Please call your sales representative for information about a 

special offer.

Example
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Create a message assignment

Create a message
assignment

Use the following procedure to create a message assignment.

...........................................................................................................................................................................

1 Select System > Message Assignments.
The system can play only one message for each function key.

...........................................................................................................................................................................

2 Select Automated, Inbound, Outbound, Transfer, or Virtual in the 
Display Type box and then click New.

...........................................................................................................................................................................

3 Type a description.

...........................................................................................................................................................................

4 Select an action in the Wait Queue Action list.
For automated message queues, your only option is Deliver Message.

...........................................................................................................................................................................

5 Select the name of the field that will contain the message number after 
preprocessing. Use the Message Field box only if you are using 
message mapping.

...........................................................................................................................................................................

6 Select the message you want the system to play in the File Name box. 
If you are using message mapping, select a default message to play if no 
matches are found for the source values you specified in the message 
map.

...........................................................................................................................................................................

7 Select File > Save.

...........................................................................................................................................................................

8 In the Save dialog box, select In Process or Complete.

If you complete all your changes and want the new file transferred to 
the system, select Complete. If you are not ready to replace the Avaya 
PDS file, select In Process.
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Note
If you have not completed all the required fields, Administration 
Manager will display an error message prompting you to complete the 
required fields. After all fields are complete, you can save successfully.
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............................................................................................................................................................................................................................................................
Telephony.spt file

Overview Each time you transfer a Message Assignment to the Avaya PDS, the 
system adds it to a file named telephny.spt. In addition to the 
lines you create, the Avaya PDS adds lines of code to complete the 
assignment. The telephny.spt file on the system may not exceed 1500 
lines. Unless you keep track of and limit the lines within this file, you 
may exceed the limit and receive an error.
If you get this error, you must take immediate action to correct the 
problem. If you do not fix the problem, with the next reboot, the Avaya 
PDS may fail to start jobs, or it may start jobs but not deliver messages 
beyond line 1500.
After completing the changes, select Data > Install Data to export 
Message Assignments to the system. To reduce the number of lines in 
the telephny.spt file, do one or more of the following:
• Delete Message Assignments that you no longer use. (You must 

delete all statuses of a message assignment—Complete, Pending 
or Live—to remove it from the telephony script file).

• Modify one or more of the Message Assignments that you 
exported.

• Contact your Avaya PDS vendor for assistance
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Delete Message Assignments

Delete Message
Assignments

Use the following procedure to delete Message Assignments.

...........................................................................................................................................................................

1 Select System > Message Assignments.

...........................................................................................................................................................................

2 Select the system in the Select System and Display Queue Type dialog 
box.

...........................................................................................................................................................................

3 Select a Display Queue Type.

...........................................................................................................................................................................

4 Select the file you want to delete and then click Delete

...........................................................................................................................................................................

5 Repeat steps 4 and 5 for each status of a message assignment you want 
to delete.

...........................................................................................................................................................................

6 Repeat steps 3 through 6 for each message assignment you want to 
remove from the telephony.spt file.

...........................................................................................................................................................................

7 Select Data > Install Data.

...........................................................................................................................................................................

8 In the Export dialog box, select the system.

...........................................................................................................................................................................

9 On the install tree, verify that Administration Manager automatically 
selected Message Data.

...........................................................................................................................................................................

10 Click OK. Administration Manager begins the data install process. The 
message data transferred to the system is installed after the next Avaya 
PDS reboot and empty data install.
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Modify one or more Message Assignments

Modify one or more
Message Assignments

Use the following procedure to modify one or more Message 
Assignments.

...........................................................................................................................................................................

1 Open a Message Assignment that has a Live status.

...........................................................................................................................................................................

2 Select Edit in the View or Edit dialog box.

...........................................................................................................................................................................

3 Reduce the number of lines in one or more of the files. Consider using a 
Start Looping statement instead of playing multiple messages.

Remember, the Avaya PDS adds lines to each Message Assignment. 
You need to allow for these lines when reducing the Message 
Assignment.

...........................................................................................................................................................................

4 When you complete your changes, select File > Save.

...........................................................................................................................................................................

5  In the Save dialog box, click Complete.
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Recording messages

Overview Your recorded voice messages must be digitized for the Avaya PDS to 
use them. You have several options for creating digitized messages. 
You can record the messages yourself and send them to a third party to 
be digitized, you can use a service bureau to record and digitize the 
messages, or you can use software that records and digitizes your 
messages. When the message is ready for use, store it in Administration 
Manager’s message subdirectory. 
The method you choose depends upon your resources. If you have a 
large number of recordings or you do not believe that you have anyone 
with an appropriate voice or language, you may want to use a service 
bureau. Some companies use service bureaus so they can match 
regional accents. Another option is to make recordings yourself as a 
way of testing the content, and then have them professionally recorded 
when you are happy with the content.

Note
If you use a service bureau to record and digitize the messages you 
must specify the message format. The service bureau can provide the 
file through the network, floppy disk, or cassette tape. 
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Message Mapping overview

Message Mapping
overview

The Message Mapping feature is optional. Message maps link wait 
queue messages to fields you select from the calling list. Use message 
mapping to customize information customers hear in the outbound wait 
queue.
For example, you can play different messages based on customer 
categories on the calling list. You define a message map to link to one 
of three messages, depending on the value the Avaya PDS finds in the 
customer ranking source field in the calling list.
Message maps can link to any field in a calling list. For example, you 
can choose the message customers hear based on their zip code, city, or 
account type. The value that appears in that field determines the 
message each customer hears.
You can link several message maps together in a script just as you can 
other messages. You can also combine messages and message maps 
together in the same script. You can use message maps with more than 
one calling list.
A message map uses the calling list in two ways. First, it looks for 
information in the field you specify (source field). You also specify the 
variables that the system looks for in this source field, and instruct the 
system what to look for.
Second, the system looks for an empty field you defined in the calling 
list (message field). The system inserts the message number that it will 
play based on the value in the source field. You can also specify a 
default message (recommended) in case no information in the source 
field matches the criteria.
You use the Message Mapping feature to define new message maps. 
Before you define a message map, you must have recorded and saved 
the messages it will use. Each calling list field you use as a source field 
for a message map must already exist on the calling list. The empty 
message field must already exist on the calling list.

Note
The Message Mapping feature may not be available on your system. If 
you would like to add this feature, contact your Avaya PDS 
representative.
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Plan When you need to create a message mapping, consider the following 
points:
• Which fields from the calling list do you want to use to select 

different messages?
• Which message do you want each type of customer to hear?
• What will you name the empty field that will receive the message 

number from the system?
• If you are using several dynamic messages in a row, how will you 

record the messages to be sure they sound like one smooth 
message?

• The telephony script file, telephny.spt, is limited to a total of 1500 
lines. This 1500 lines must serve all script lines for all calling lists 
handled by the system.

• Each message is limited to one minute.
• The system can store a total of 35 minutes of recorded messages, 

or up to 1970 messages.

Example
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Create a message map

Create a message map Use the following procedure to create a message map.

...........................................................................................................................................................................

1 Select Application > Message Map.

...........................................................................................................................................................................

2 Select the system and then click New.

...........................................................................................................................................................................

3 Name the message map. You can use a maximum of eight alphanumeric 
characters.

...........................................................................................................................................................................

4 Select the source field in the calling list (for example, ZIPCODE.) The 
Avaya PDS compares the data in this field to the source values on the 
message map to determine which message is played.

...........................................................................................................................................................................

5 Select the name of the empty field you created in a calling list for the 
message number in the Message Field box. 

...........................................................................................................................................................................

6 Click OK. You cannot edit the fields after you click OK. You can only 
delete and re-enter the information.

...........................................................................................................................................................................

7 Type a description of the message map.

...........................................................................................................................................................................

8 Enter the value or range of values that the Avaya PDS will look for in 
the source field in the Source Value box. For example, ZIPCODE = 
98000-99999 to play a specific message for customers within 
Washington state.

...........................................................................................................................................................................

9 Select the message to play in the Message Value box when the source 
value or a value within the range is found.
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...........................................................................................................................................................................

10 Repeat steps 9 and 10 for each set of variables. In the Save dialog box, 
select In Process or Complete.

Note
Message Maps have a “last one wins” rule if more than one message 
number is selected to be placed in the message field. If criteria for the 
same message field matches more than one source field in your 
message map, the last message number processed will play. If you are 
using more than one message map, the last message number processed 
on the last message map will play.
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Message value wildcard characters

Overview When you specify criteria for a field, you use an expression to define 
the subset of records you want to use. An expression is a combination 
of wildcard characters such as greater than (>) or less than (<), and 
other values.

Wildcard characters Message Mapping uses the following wildcard characters:.

If you want customers with a balance greater than $5000 to hear a 
message about account insurance, your expression might be >5000 in 
the ACCTBAL source field. Then specify the name of the message that 
corresponds to accounts of that size.

Wildcard character Description

= equal to

<> or ~ not equal to

> greater than

< less than

>= greater than or equal to

<= less than or equal to

IS EMPTY match on empty field

IS SPACE match on space-only field

* match all

? match on single character

, match on one value in a series

- match on any value in a range
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Select a message map

Select a message map Use the following procedure to select a message map.

...........................................................................................................................................................................

1 Select Application > Calling List.

...........................................................................................................................................................................

2 Select the system and the calling list in the Calling List - Select 
Application dialog box.

...........................................................................................................................................................................

3 Select the Message Map tab in the Calling List - [filename] dialog box.

A pull-down menu lists names of all existing message maps. You can 
add more lines by selecting Append.

...........................................................................................................................................................................

4 Select the message map(s) to associate with this calling list. You can 
move your choices up or down, or delete lines.

...........................................................................................................................................................................

5 Save your selections. Select In Process or Complete.
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Overview

Purpose In Administration Manager, an application is an association of calling 
lists and download and upload file definitions.

Contents This section contains the following topics:
• Applications overview
• Create an application
• Select an application
• Copy an application
• Delete an application
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Applications overview

Applications overview Administration Manager defines an application as an association of 
calling lists and download and upload file definitions. When you create 
an application in Administration Manager, you specify either an 
inbound or outbound calling list. 
Typically, an outbound calling list begins with information provided by 
the host, in the form of a data file. The field layout you define on 
Administration Manager must match the layout of the data file received 
from the host computer. Check your work carefully.
The Avaya PDS processes the data file received from the host 
computer, checks for records that are duplicated or that contain invalid 
telephone numbers, and marks those records as ineligible for calling.
Marking the ineligible records and adding the system fields changes the 
host computer data file into an Avaya PDS calling list. The Avaya PDS 
uses the calling list to make phone calls, display customer information 
on agent screens, and save the results of calls.
At the end of each remaining record, the Avaya PDS appends empty 
data fields. These data fields will contain information about the 
activities completed during your daily calling operations. For example, 
the data fields will store the agent’s login name, the results of the call, 
and the duration of each call.
The Avaya PDS identifies each outbound calling list as list followed by 
a number up to 500 (for example, list1).

Inbound calling lists The format of the customer records stored in your inbound list varies 
depending on the type of business you do and how you interact with 
your host computer.
If your agents work directly with a host computer, your inbound list 
may contain only a single custom field. Agents use the information in 
this field to query the host computer for an account record. This field 
should uniquely identify each record in the database. Typical fields for 
this purpose are ACCTNUM and PHONE1.
In a stand alone system where no host is available, the format of the 
inbound list may be similar to your outbound calling list. However, the 
fields contain no data, because their function is to accept new 
information gathered during calling activities.
Since you can use Administration Manager to define more than one 
application, you must select a calling list name before you begin a task. 
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When you select the Download, Calling List Format, Inbound List 
Format, or Upload command from the Application menu, the Select 
Application dialog box appears. There are several types of Select 
Application dialog boxes, but they all serve the same purpose. If the 
dialog box has a Display filter group, you can limit the dialog box 
display to a particular completion status.
The system identifies each inbound list as inbnd followed by a number 
up to 500 (for example, inbnd1).

Application copy You can copy an application to a new application name on the same 
Avaya PDS or to another Avaya PDS. When you copy an application, 
Administration Manager copies the download, calling list or inbound 
list, upload, and file processing definitions from one application to 
another. Administration Manager copies each definition in the 
following preference order: In Process, Complete, Pending, Live. All 
definitions in the new application are assigned an In Process status. For 
example, if there is an In Process download definition, Administration 
Manager copies it to the new application. If there is a Complete 
download definition (but no In Process definition), the Complete 
definition is copied to the new application and assigned a status of In 
Process

Delete an application You can also delete applications. Deleting an application deletes all 
download, calling list, upload, and file processing information for that 
application. It also deletes the processed calling or inbound list on the 
Avaya PDS the next time you use the Install Data feature. The Avaya 
PDS stores a copy of the deleted list for up to seven days. Depending 
on the size of the backup list and other data on the system, hard disk 
space might be limited.

Important
Be careful when deleting an application. You cannot undo this action.

Plan When you need to create a new application, consider the following 
questions before using Administration Manager:
• Will this application be used with an inbound or outbound calling 

list?
• If you have more than one Avaya PDS, which one will use this 

application?
• What fields may be needed in addition to the downloaded data file 

fields for your agents to be productive?
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Note
When you add new applications or change existing applications using 
Administration Manager, it does not automatically update your Avaya 
PDS reports. You can use PC Analysis or Analyst to design similar 
reports or contact your Avaya PDS vendor to update your system 
reports.
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............................................................................................................................................................................................................................................................
Create an application

Create an application Use the following procedure to create an application.

...........................................................................................................................................................................

1 Select Application > Application Definition.
The New Application dialog box appears.

...........................................................................................................................................................................

2 Select the system in the System box.

...........................................................................................................................................................................

3 Type a unique number in the List # box.

...........................................................................................................................................................................

4 Type a description (up to 40 alphanumeric characters) of the application 
in the List description box.

...........................................................................................................................................................................

5 Select the type of application (outbound or inbound) in the Type box.

...........................................................................................................................................................................

6 Select File > Save.
The new application appears in the Current Applications list.
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Select an application

Select an application Use the following procedure to select an application.

...........................................................................................................................................................................

1 Select a system from the System list.

...........................................................................................................................................................................

2 Select the application and then click OK.
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Copy an application

Copy an application Use the following procedure to copy an application.

...........................................................................................................................................................................

1 Select Application > Application Copy.

...........................................................................................................................................................................

2 Select the system that contains the application you want to copy under 
Existing Application Lists.

...........................................................................................................................................................................

3 Select the application name to copy.

...........................................................................................................................................................................

4 Select the system to which you want to copy the application under New 
Application list.

...........................................................................................................................................................................

5 Type a unique number for the application.

...........................................................................................................................................................................

6 Type a description for the application.

...........................................................................................................................................................................

7 Select File > Save.
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Delete an application

Delete an application Use the following procedure to delete an application. Remember, this 
action cannot be undone.

...........................................................................................................................................................................

1  Select Application > Application Delete.

...........................................................................................................................................................................

2 Select the system that contains the application you want to delete.

...........................................................................................................................................................................

3 Select the application name to delete.

...........................................................................................................................................................................

4 Select Edit > Delete Row.
Administration Manager displays a message asking you to confirm the 
deletion.

...........................................................................................................................................................................

5 Click OK.
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Overview

Purpose The download process transfers data from the host computer to the 
AvayaTM Predictive Dialing System (PDS) where it is converted to an 
outbound calling list. Use the download feature to set up the file 
formats and file transfer details used to transfer files from the host 
computer to the system. You download information from the host to an 
Avaya PDS calling list in either ASCII or standard IBM (EBCDIC) file 
format.

Contents This section contains the following topics:
• Download overview
• Edit download field names
• Special formats
• Create special formats
• Special field symbols
• Add field filler information
• Add data translations
• Merge fields
• Create the download file structure
• Complete an FTP download
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• Complete a tape download
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Download overview

Overview Using the download feature, you provide the Avaya PDS with three sets 
of information.
• You provide information about the layout of the host data file and 

the field attributes of each record.
• You describe the format, block size, and file structure used in the 

host data file.
• You define how the data transfer occurs. You can load host data 

onto the system using FTP or tape. (If your system is currently set 
up to use a host gateway, you can select the host gateway transfer 
method.)

In each download, you must include the host fields the Avaya PDS uses 
to select records, to display on agent screens, and to include in Avaya 
PDS reports. Include at least one phone number. Gather the necessary 
format and file transfer information from your Avaya PDS 
administrator.

Host Gateway LAN file
transfer

If you use a Host Gateway LAN for file transfer, a radio button will 
already be selected for that option in Administration Manager. Do not 
change this to another option! If you do, you will lose that ability and 
will have to have it reconfigured.
The Host Gateway LAN file transfer option is obsolete with Avaya 
PDS 12.0. If you have an earlier version of the Avaya PDS,  you can 
still use it. But remember, do not change file transfer methods in 
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Adminstration Manager or you will lose the ability to transfer files via 
Host Gateway LAN.

Edit download field names The Fields tab is used to specify the information you want to download 
from the host. For example, the host file may contain information 
ranging from the customer name and account number to the date of the 
last purchase and balance due. You may want to download only some 
of this information to your calling list. Before you edit download field 
names, you must define an application. 

Data Types When defining download fields, you must choose a data type. Data 
types are:
• Text
• Date
• Money
• Numeric
• Phone
• Time
If you select Phone, Administration Manager automatically sets the 
field name to PHONE1, PHONE2, and so on. If a field contains both 
alpha and numeric characters, select Text as the data type. You may 
also select Text for all numeric data if it is not used in any calculation.

Use Same Start You can use the same information to populate different fields. For 
example, PHONE1 contains the 10-digit phone number. The 
AREACODE field takes the 3-digit area code from the PHONE1 field. 
Because Same Start is selected, AREACODE and PHONE1 display the 
same value (21) under Start. The field following the AREACODE field 
begins at the end of the longer field (PHONE1).

Plan When you need a new download definition, consider the following 
questions before using Administration Manager:
• Which fields from the host file do you want to download?
• What is the format of the host file information?
• Is there any special formatting you want to apply to the 

downloaded data?
• How do you want the data displayed in the calling list?
• What is the file and record structure of the host data?
• What download method do you use (FTP or tape)?
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• Which fields will you want on the agents’ screens?
• Which fields will you need to select records?
• Which fields will you want for system reports?
• Which fields will you need for record keeping or order 

processing?

Note
When you add new applications or change existing applications using 
Administration Manager, it does not automatically update your system 
reports (such as the Reject and Days on Avaya PDS reports). You can 
use PC Analysis or Analyst to design similar reports or contact your 
Avaya PDS vendor to update your system reports.

Example Use Application > Download to tell the Avaya PDS which fields the 
host will download and to define the format for each download list. 
After filling out the Download dialog box and saving your work, you 
will have created a download file definition.
The Download dialog box has three tabs: Fields, Structure, and 
Method.
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Edit download field names

Edit download field names Use the following procedure to edit download field names.

...........................................................................................................................................................................

1 Select Application > Download.

...........................................................................................................................................................................

2 Select Application dialog box and then select the system.

...........................................................................................................................................................................

3 Select the application and then click OK.

...........................................................................................................................................................................

4 Type the name of the first field (up to 15 alphanumeric characters) in the 
download In the Field Name box. Names appear in uppercase.

...........................................................................................................................................................................

5 Select the type of information that appears in this field.

...........................................................................................................................................................................

6 In the Length box, type the number of characters in the field.

...........................................................................................................................................................................

7 Select the Same Start check box if this field uses the same data as the 
previous field.

...........................................................................................................................................................................

8 Type a description of the field.

...........................................................................................................................................................................

9 Click the Special button if you want to apply special formatting to the 
field. 
For more information, see Special formats.

...........................................................................................................................................................................

10 Repeat steps 4 through 9 for each field you want to download.

...........................................................................................................................................................................

11 Select File > Save.
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...........................................................................................................................................................................

12 In the Save dialog box, select In Process or Complete.
If you complete all your changes and want the download definition 
transferred to the system, select Complete. If you are not ready to 
transfer the definition, select In Process.
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Special formats

Overview You can apply special formatting to fields downloaded from the host to 
meet Avaya PDS requirements. Use the special format feature to define 
the following:
• How you want the system to display the data
• What information you want to force into a selected field
• How to convert specific values of a field to different values
• Fields you want to combine into a single field
Use the Format tab to define how you want host data displayed in the 
calling list.
For example, you can add dashes to a phone field’s format or add a 
decimal point to a dollar value. The Host format and Avaya PDS format 
drop-down lists contain commonly used special formats. You can select 
from these lists or type your own formats, including literal characters.
The following illustration shows an example of the Format tab in the 
Special Format dialog box.

Special format: merge Use the Merge tab to identify fields you want to combine into another 
field. You must define the download fields that you want to combine 
before you can define the merge field.
Add the merge field on a row below the download fields that you want 
to merge. It is recommended that you add merge fields below all 
download fields.
For example, the area code, exchange, and line number have each been 
defined as separate fields on the Download Fields tab. You define the 
fourth field (PHONE1) for the complete phone number and use the 
Special Format - Merge feature to combine the values from the area 
code, exchange, and line number fields.
7 - 7 4



Download data
............................................................................................................................................................................................................................................................

Note
The Avaya PDS requires the entire phone number (area code, 
exchange, and line) in a single field. If you need to break out the area 
code, exchange, and line in separate fields for other purposes, use the 
Special Format’s Merge feature. Administration Manager correctly 
calculates the system added fields PHONESTAT & ZONEPHONE. 
This is done by using the special formatting feature Merge. The 
AREA< PREFIX, and SUFFIX are separate fields; the PHONE1 field 
follows the SUFFIX field. Use Data type Text instead of Data type 
Phone for PHONE1. The special formatting check box is selected, and 
the fields for AREA, PREFIX, and SUFFIX are added for the MERGE 
field for PHONE1

Special format: translate Use the Translate tab to identify specific field values you want to 
convert to different values. For example, you can convert ZIP codes to 
cities.

Special format: Structure Use the Structure tab to provide the Avaya PDS with information 
about the host file structure and size. The Avaya PDS uses this 
information to read the host data and process the download file.
If your system is year 2000 compliant and your Administration 
Manager system supports the Switch Year feature, use the Structure tab 
to set a switch year value. The system uses this number to convert the 
year in a date field from two to four digits. If a downloaded two-digit 
year is greater than or equal to the switch year, the system inserts 19 
into the century position of the date. For values less than the switch 
year, the system inserts 20 into the date. For example, if the switch year 
value is 30 and the downloaded year value is 95, the system inserts 19 
(1995). If the downloaded value is 05, the system inserts 20 (2005). 
Define a switch year value based on your data and business needs.
Consider how far beyond the year 2000 your data extends.
If you use the Switch Year feature, you must also define special formats 
for your date fields. 
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Complete the fields that apply to this download. Required fields are 
noted in the applicable step.
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Create special formats

Create special formats Use the following procedure to define special field formatting.

...........................................................................................................................................................................

1 Select the field you want on the Download Fields tab and then click the 
Special button.
The Special Format dialog box appears. Select the Host field only 
option if you do not want to copy this field to the calling list (for 
example, FILLER1).

...........................................................................................................................................................................

2 Select or type the format of the data in the host record in the Host 
format box.
The items available in the Host and Dialer format boxes depend on the 
field’s data type. 

...........................................................................................................................................................................

3 Select or type the format that you want the data displayed on the system 
in the Dialer format box and then click OK.
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Special field symbols

Special field symbols Administration Manager uses the following symbols to represent 
specific types of characters or information.

If you define a special format that inserts a character into a field, you 
must insert a space in the host format that corresponds to the new 

Data Type Symbol Description

Text, Phone @ Alphanumeric characters and phone 
numbers

Number # Numeric, with leading zeros

Money $ Numeric, without leading zeros, left 
justified digits

Date MM Month

DD Day

YY Year

CC Century (Use in the host and dialer 
formats when the host download file 
includes the century digits.)

NN Century (Use in the dialer format to 
insert the century digits calculated 
by the Switch Year feature.)

19 Century (Use in the dialer format to 
insert 19 before the two digit year.)

20 Century (Use in the dialer format to 
insert 20 before the two digit year.)

Time HH Hour

MM Minutes

SS Seconds

All data types (space) Place holder (Use in the host format 
to insert a character in the dialer 
format, such as a dash or a decimal 
point.)
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character in the dialer format. For example, to insert a decimal point 
into a money field, type the host format with a space where you want to 
locate the decimal point (###### ##). Type the decimal point in the 
dialer format ($$$$##.##).
If your system is year 2000 compliant, you need to define how to 
handle the century digits for date fields. Use one of the following 
methods:
• If a host download file contains eight-digit date fields that include 

the century, use the symbol CC to define the century digits in the 
date format.

• If a host download file does not include the century digits in the 
date fields and the Switch Year feature is set up on Administration 
Manager, use the symbol NN to define the century digits in the 
date field’s dialer format.

• If Administration Manager is not set up to use Switch Year, you 
can define specific century digits that you want the system to 
insert into a date field. For example, if you insert 19 into a date 
field’s dialer format, the system will insert 19 into that date field in 
every record of the calling list.

Note
Administration Manager does not require you to insert spaces in the 
host format to represent inserted century digits in the dialer format.

Special formatting for
downloads

The following table lists examples of how to use special formatting for 
downloads, including sample host and dialer data.

Host Format Dialer Format Host Data Dialer Data

@@@ @@@ 
@@@@ 
(phone number)

@@@-@@@-
@@@@

2065554259 206-555-4259

#### ## $$$#.## 059095 $590.95

#### ## $$##.## 000995 $09.95

MM DD YY MM/DD/YY 061898 06/18/98

CCYY MM DD MM/DD/CCYY 19980618 06/18/1998
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YY MM DD MM/DD/
NNYY

980618 06/18/1998 
The example 
is based on a 
switch year 
value of 30.

MM DD YY MM/DD/
NNYY

061805 06/18/2005 
The example 
is based on a 
switch year 
value of 30.

YY MM DD YY/DD/19YY 980618 06/18/1998

MM DD YY MM/DD/20YY 061805 06/18/2005

HH MM SS HH.MM.SS 102050 10.20.05

@@@ @@ 
@@@@ (social 
security 
number)

@@@-@@-
@@@@

123456789 123-45-6789

Host Format Dialer Format Host Data Dialer Data
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............................................................................................................................................................................................................................................................
Add field filler information

Add field filler information Use the following procedure to add field filler information.

...........................................................................................................................................................................

1 Select the field you want on the Download Fields tab and then click 
Special.

...........................................................................................................................................................................

2 Select the Insert Data tab in the Special Format dialog box.

...........................................................................................................................................................................

3 Type the information you want to force into the selected field in Fill 
info. 
The system inserts into the field exactly what you type. For example, if 
you want to fill a five-character field with asterisks, type five asterisks.

...........................................................................................................................................................................

4 Click OK.
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............................................................................................................................................................................................................................................................
Add data translations

Add data translations Use the following procedure to add data translations.

...........................................................................................................................................................................

1 Select the field you want and click Special on the Download Fields tab.

...........................................................................................................................................................................

2 Select the Translate tab in the Special Format dialog box and then 
click Append.

...........................................................................................................................................................................

3 Type the data as it appears in the host field in the Host data box.
Leave the field blank to represent a null field. Press the spacebar to enter 
a space character.

...........................................................................................................................................................................

4 Type the data you want in the downloaded field in the Dialer data box.
Leave the field blank to represent a null field. Press the spacebar to enter 
a space character.

...........................................................................................................................................................................

5 Repeat steps 3 through 5 for each data pair you want to define.

...........................................................................................................................................................................

6 Type the default value you want to use when the host field contains a 
value that doesn’t appear in the Host data list in the Dialer default field. 
This is an optional entry. The calling list uses this value if no match is 
found between the host field value and values in the Host data list. If you 
leave this field blank, the calling list field is left empty when no match 
is found.

...........................................................................................................................................................................

7 Click OK.
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............................................................................................................................................................................................................................................................
Merge fields

Merge fields Use the following procedure to merge fields.

...........................................................................................................................................................................

1 Select the field you want and click Special on the Download Fields tab.

...........................................................................................................................................................................

2 Select the Merge tab in the Special Format dialog box.

...........................................................................................................................................................................

3 Select the first field you want to merge and click > button in the 
Available host fields list.

...........................................................................................................................................................................

4 Repeat step 3 for each field you want to merge. 
Administration Manager merges the field data in the order listed in the 
Merge fields list.

...........................................................................................................................................................................

5 Click OK.
When you define a merged field, no Start and End positions are 
calculated on the Fields tab. 
7 - 8 3



Download data
...........................................................................................................................................................................................................................................................

............................................................................................................................................................................................................................................................
Create the download file structure

Create the download file
structure

Use the following procedure to create the download file structure.

...........................................................................................................................................................................

1 Select the Structure tab in the Download dialog box.

...........................................................................................................................................................................

2 Type the size of one host record if necessary, in the Record Size box. 
By default, Administration Manager displays the ending position for the 
last field defined on the Fields tab. This field must contain an entry.

...........................................................................................................................................................................

3 Type the size of the buffer in which the records are stored in the Block 
Size box.
By default, Administration Manager displays the record size. However, 
the system converts the data more efficiently when you increase the 
block size. This value must be a multiple of the Record size entry and 
less than 32,000. If you are unsure what to enter, multiply the record size 
by 10. This field must contain an entry.

...........................................................................................................................................................................

4 Type the number of blocks to read in the Blocks Read box. 
Administration Manager displays a default value of 1. The 
recommended setting is 10. Blocks Read multiplied by Block Size (the 
number of bytes that the system reads before processing the data) must 
not exceed 32,000. If Blocks Read is too high, the system converts no 
records and displays no error statements. This field must contain an 
entry.
Administration Manager does not automatically update the Structure tab 
if you change the record length on the Fields tab. You must type the new 
Record Size, Block Size, and Blocks Read settings to reflect the new 
record length.

...........................................................................................................................................................................

5 Type the number of bytes in the host file to skip before beginning data 
conversion and writing in the Skip Records box.
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...........................................................................................................................................................................

6 Type the number of bytes to convert and write in the Read Bytes box.

...........................................................................................................................................................................

7 Type a two-digit year number in the Switch Year box. Complete this 
field if your system is year 2000 compliant and your Administration 
Manager system supports the Switch Year feature.

...........................................................................................................................................................................

8 Select the value (null or space) to place in every blank position for all 
fields in each record in the Terminator list.

...........................................................................................................................................................................

9 Select the data type (ASCII or EBCDIC) of the host file in the 
Character Set list. This field must contain an entry.

...........................................................................................................................................................................

10 Select the method to use to handle type case in the Case Conversion 
list.
The default is UPlow (leave case as is). Other options are UPPER 
(convert all characters to uppercase) and lower (convert all characters to 
lowercase).

...........................................................................................................................................................................

11 Select Remove carriage return to remove carriage returns from each 
record.

...........................................................................................................................................................................

12 Select the Remove line feed check box to remove line feeds from each 
record.

...........................................................................................................................................................................

13 Type the name of the custom download process for your system 
(optional) in the Custom Executable box.

...........................................................................................................................................................................

14 Select File > Save.

In the Save dialog box, select In Process or Complete.
If you complete all your changes and want the download definition 
transferred to the system, select Complete. If you are not ready to 
transfer the definition, select In Process.
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Complete an FTP download

Complete an FTP download Use the following procedure to complete an anonymous FTP 
download.

...........................................................................................................................................................................

1 Select Application > Download.

...........................................................................................................................................................................

2 Select the system in the Download - Select Application dialog box.

...........................................................................................................................................................................

3 Select the application and click OK.

...........................................................................................................................................................................

4 Select the Method tab, and then select FTP.

...........................................................................................................................................................................

5 In the Server Name box, type the system name for the host computer.

...........................................................................................................................................................................

6 In the Logon box, type the logon user name for the host computer.

...........................................................................................................................................................................

7 In the Password box, type the logon password for the host computer. 
If you complete all your changes and want the download definition 
transferred to the Avaya PDS, select Complete. If you are not ready to 
transfer the definition, select In Process.

...........................................................................................................................................................................

8 In the Host File box, type the path and file name of the file on the host 
system.

...........................................................................................................................................................................

9 Select File > Save.

...........................................................................................................................................................................

10 In the Save dialog box, select In Process or Complete.
If you complete all your changes and want the definition transferred to 
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the Avaya PDS, select Complete. If you are not ready to transfer the 
definition, select In Process.
7 - 8 7



Download data
...........................................................................................................................................................................................................................................................
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Complete a tape download

Complete a tape download If you use 9-track tape to transfer information between the Avaya PDS 
and the host computer, use the following procedure to complete a tape 
download.

...........................................................................................................................................................................

1 Select Application > Download.

...........................................................................................................................................................................

2 Select the system in the Download - Select Application dialog box.

...........................................................................................................................................................................

3 Select the application and then click OK.

...........................................................................................................................................................................

4 Select the Method tab and then select Tape.

...........................................................................................................................................................................

5 Select the tape density in the Density box.
/dev/rmt/2hsn for high density tape
/dev/rmt/2msn for low density tape

...........................................................................................................................................................................

6 Select the type of tape header (IBM or none) in the Label box.
If you select IBM, the Avaya PDS skips the header information at the 
beginning of the file.

...........................................................................................................................................................................

7 Select File > Save.

...........................................................................................................................................................................

8 In the Save dialog box, select In Process or Complete.
If you complete all your changes and want the definition transferred to 
the Avaya PDS, select Complete. If you are not ready to transfer the 
definition, select In Process.
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............................................................................................................................................................................................................................................................
Overview

Purpose The AvayaTM Predictive Dialing System (PDS) uses calling list 
information to convert downloaded host data into an Avaya PDS 
outbound calling list.

Contents This section contains the following topics:
• Calling list definition overview
• Track call results
• Edit calling list fields
• Prepare calling list
• Edit list preparation details
• Edit update settings
• Customize calling list processing
• Link a message map to the calling list
• Specify calling list processing order
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Calling list definition overview

Calling list definition
overview

When you need to create a calling list definition, consider the following 
questions before using Administration Manager:
• What fields do you want the system to add for tracking calling 

activities?
• If you are using message mapping, what fields do you need to add 

for message maps?
• Which field do you want to use for duplicate checking?
• What call results do you want to track?
• Do you want to index the calling list?
• Do you want to mark records as not callable after they have been 

on the system for a specified length of time? If so, how long?
• If you download host records on consecutive days, do you want to 

update the returning records with the previous day’s results?
• Are there custom processes you want to run against this calling 

list?
• In what order do you want your custom processes to run?

Note
When you add new applications or change existing applications using 
Administration Manager, it does not automatically update your system 
reports (such as the Reject Record and Days on Avaya PDS reports). 
You can use PC Analysis or Analyst to design similar reports or contact 
your Avaya PDS vendor to update your system reports.

Important
When creating a calling list definition, complete the Calling List tabs in 
order from left to right.
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Call results tracking Use the Features tab to identify the call results you want the Avaya PDS 
to track for due diligence. Due diligence, also called post-update, is an 
optional feature that the system uses to track the number of call 
attempts to a record. For each call attempt, the Avaya PDS tracks the 
date, time, and call result for the number of phones selected. It is 
particularly helpful to industries that are required to contact a customer 
a minimum number of times before taking an action. For example, 
some institutions cannot refer a past due account to a collection agency 
until the institution has made four unsuccessful attempts to contact the 
delinquent account.

Note
To use this feature, Due Diligence must have been selected during 
Administration Manager system setup. Contact your system installer if 
fields on the Features tab are disabled.

Calling list fields Use the Fields tab to display information about all fields in the calling 
list and to define custom fields, which are placed between the host 
fields and Avaya PDS-added fields. For example, you may want to add 
a comment field that agents use to type any call information that 
doesn’t fit into other fields, or define an empty Message Field for a 
message map.
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You can select the type of calling list fields you want to view.

Note
To display fields defined using the Download feature, select Refresh 
Calling List from the Edit menu.

Calling list field preparation Use the Prepare tab to specify how a calling list is processed, tracked, 
and reported. For example, you can define duplicate and reject record 
checks, ZIP Code conversion to area codes, and calling list record 
indexing.

Update settings Use the Update tab to specify the update criteria for this calling list. 
Use this feature when you download host records on consecutive days 
and want to update the returning records with the previous list’s results.

Customize calling list
processing

Use the Custom tab to define custom processing for the calling list. You 
can add or remove processing programs that have been designed 
specifically for your system.

Note
Not all systems have this option.

Calling list processing
order

Use the Ordering tab to define the order for all processing on this 
calling list. You can change the order of the custom processing you 
select.

Warning
You can also change the standard processing order. However, this may 
interrupt the calling list processing before it is complete or destroy the 
calling list. You cannot remove time zone processing.

Select To display

All All calling list fields

Download You can select the type of calling list fields you want to 
view.

Input Custom fields only

Dialer Avaya PDS-added fields only
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............................................................................................................................................................................................................................................................
Track call results

Track call results Use the following procedure to track call results.

...........................................................................................................................................................................

1 Select Application > Calling List.

...........................................................................................................................................................................

2 Select the system in the Calling List - Select Application dialog box.

...........................................................................................................................................................................

3 Select the application and click OK.
Administration Manager displays the Calling List dialog box with the 
Features tab selected.

...........................................................................................................................................................................

4 Select the Maintain calling activity history check box.

...........................................................................................................................................................................

5 Select Ignore subsequent attempts or Overwrite initial attempts.
If you select Ignore subsequent attempts, the system tracks only the 
number of attempts selected.
If you select Overwrite initial attempts, the system overwrites the calling 
activity history on the oldest attempt with the results of the most recent 
attempt after the selected number of attempts has been reached.

...........................................................................................................................................................................

6 Select the number of phone fields (up to 4) in the calling list that you 
want to track. A minimum of 2 phone fields is required.

...........................................................................................................................................................................

7 Select the number of attempts (up to 5) to call a record. A minimum of 
2 attempts is required.

...........................................................................................................................................................................

8 Select each completion code for which you want to track calling activity 
history.

...........................................................................................................................................................................

9 Select File > Save.
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...........................................................................................................................................................................

10 In the Save dialog box, select In Process or Complete.
If you complete all your changes and want the definition transferred to 
the system, select Complete. If you are not ready to transfer the 
definition, select In Process.
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............................................................................................................................................................................................................................................................
Edit calling list fields

Edit calling list fields Use the following procedure to edit calling list fields.

...........................................................................................................................................................................

1 Select the Fields tab in the Calling List dialog box.

...........................................................................................................................................................................

2 Select an option under Display by Calling List Source.

...........................................................................................................................................................................

3 Type a name for the custom field (up to 15 alphanumeric characters) in 
the Field Name box.

...........................................................................................................................................................................

4 Select the data type for this field in the Type box.

...........................................................................................................................................................................

5 Type the number of characters in the field in the Length box.

...........................................................................................................................................................................

6 Type a brief description n the Description box.

...........................................................................................................................................................................

7 Select the Enable Data Transfer check box if you want to transfer the 
data in this field during a voice and data transfer.

...........................................................................................................................................................................

8 Repeat steps 3 through 7 for each custom field you want to define.

...........................................................................................................................................................................

9 Select File > Save.

...........................................................................................................................................................................

10 In the Save dialog box, select In Process or Complete.
If you complete all your changes and want the calling list definition 
transferred to the system, select Complete. If you are not ready to 
transfer the definition, select In Process.
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............................................................................................................................................................................................................................................................
Prepare calling list

Prepare calling list Use the following procedure to prepare a calling list.

...........................................................................................................................................................................

1 Select the Prepare tab in the Calling List dialog box.

...........................................................................................................................................................................

2 Select Remove duplicate records in the Duplicate Entry and Reject 
Records box to enable this feature.

...........................................................................................................................................................................

3 Select the field to use to identify duplicate records in Duplicate Field. 
Typical choices are the ACCTNUM or PHONE1 field.

...........................................................................................................................................................................

4 To exclude records meeting specific criteria. In the Field box, select a 
field name. In the Value box, type a field value. If the field contains this 
value, the record is marked as not callable.
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............................................................................................................................................................................................................................................................
Edit list preparation details

Edit list preparation details Use the following procedure to edit list preparation details.

...........................................................................................................................................................................

1 Select the Index calling list check box, and then select a unique key 
field to index the calling list. This provides faster record access for 
processes such as Record Edit or Campaign Batch Update. A typical 
choice is ACCTNUM.

...........................................................................................................................................................................

2 Select the Insert area code based on ZIP Code check box, then select the 
ZIP Code field to perform a ZIP-to-area code conversion. Select this 
option when your ZIP Code data is more accurate than your area code 
data. You must have a current ZIP Code to area code database installed 
on the system.

...........................................................................................................................................................................

3 To track the number of days a record has been on the system, select 
Calculate consecutive days on system, and then define the following:
— In the Sort field box, select a unique field to use to match records 
between the new calling list and the previous calling list. A typical field 
choice is ACCTNUM.
— In the Maximum Consecutive days box, select the number of days 
that a record can remain on the system before it is marked as old.
— In the Days in Work Week box, select the number of days in the call 
center’s work week.
— To mark records identified as old as not callable, select Delete 
records reaching maximum days. The system places a D (delete) in the 
record’s STATUSFLAG field when it has been on the system for the 
defined maximum consecutive days.

...........................................................................................................................................................................

4 Select File > Save.

...........................................................................................................................................................................

5 In the Save dialog box, select In Process or Complete.
If you complete all your changes and want the calling list definition 
transferred to the system, select Complete. If you are not ready to 
transfer the definition, select In Process.
8 - 9 7



Calling lists
...........................................................................................................................................................................................................................................................

............................................................................................................................................................................................................................................................
Edit update settings

Edit calling list update
settings

Use the following procedure to edit update settings.

...........................................................................................................................................................................

1 Select the Update tab in the Calling List dialog box.

...........................................................................................................................................................................

2 Select Update List to enable the update feature.

...........................................................................................................................................................................

3 Select the key field that identifies a record for update in the Match on 
Unique Field box. A typical choice is ACCTNUM.

...........................................................................................................................................................................

4 Select the field(s) you want to update in the Selectable Fields box and 
then press >.
To select multiple fields, hold down the Ctrl key and click the field 
names.

...........................................................................................................................................................................

5 Select the Results to Track check box for each completion code you 
want to track.

...........................................................................................................................................................................

6 Select File > Save.

...........................................................................................................................................................................

7 In the Save dialog box, select In Process or Complete.
If you complete all your changes and want the calling list definition 
transferred to the system, select Complete. If you are not ready to 
transfer the definition, select In Process.
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Customize calling list processing

Customize calling list
processing

Use the following procedure to customize your calling list processing.

...........................................................................................................................................................................

1 Select the Custom tab in the Calling List dialog box.

...........................................................................................................................................................................

2 Select the custom processing you want to add in the Available Calling 
List Processing list.
To select multiple processes, press the Ctrl key and click the items you 
want.

...........................................................................................................................................................................

3 Click > to move the selected item(s) to the Selected Calling List 
Processing list.
To remove processes from the list, select the item(s) and click <.

...........................................................................................................................................................................

4 Select File > Save.

...........................................................................................................................................................................

5 In the Save dialog box, select In Process or Complete.
If you complete all your changes and want the calling list definition 
transferred to the system, select Complete. If you are not ready to 
transfer the definition, select In Process.
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............................................................................................................................................................................................................................................................
Link a message map to the calling list

Link a message map to the
calling list

Use the following procedure to link message maps to this calling list.

...........................................................................................................................................................................

1 Select the Message Map tab in the Calling List dialog box.

...........................................................................................................................................................................

2 Click Append to add more message maps.

...........................................................................................................................................................................

3 Select the message map to associate with this calling list. Message maps 
must appear in the order (top to bottom) they will be used.You can move 
your choices up or down or delete lines.

...........................................................................................................................................................................

4 Save your selections.
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............................................................................................................................................................................................................................................................
Specify calling list processing order

Specify calling list
processing order

Use the following procedure to specify calling list processing order.

...........................................................................................................................................................................

1 Select the Ordering tab in the Calling List dialog box.

...........................................................................................................................................................................

2 Select the item you want to move.

...........................................................................................................................................................................

3 Select Edit > Move Up or Edit > Move Down to move the item up or 
down in the list.

...........................................................................................................................................................................

4 Repeat steps 2 and 3 for each item you want to move.

...........................................................................................................................................................................

5 Select File > Save.

...........................................................................................................................................................................

6 In the Save dialog box, select In Process or Complete.
If you complete all your changes and want the calling list definition 
transferred to the system, select Complete. If you are not ready to 
transfer the definition, select In Process.
8 - 1 0 1



Calling lists
...........................................................................................................................................................................................................................................................
8 - 1 0 2



9 Inbound lists
............................................................................................................................................................................................................................................................

............................................................................................................................................................................................................................................................
Overview

Purpose You can use Administration Manager to create empty inbound lists for 
use with Intelligent Call Blending.

Contents This section contains the following topics:
• Inbound lists
• Create an inbound list
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............................................................................................................................................................................................................................................................
Inbound lists

Overview Inbound lists are templates that contain fields but no data. You create 
inbound lists for Intelligent Call Blending® systems. The inbound lists 
store data about the type of calls the Avaya PDS. Agents complete data 
fields and the information can be uploaded to the host. When you 
define an inbound list, you assign a number to it; Administration 
Manager automatically adds the prefix inbnd (for example, inbnd1 or 
inbnd2). You define one set of data for each inbound list, including a 
unique identifier for accessing the records on the host and uploading 
the records to the host. The unique identifier is a group of characters is 
unique to each record, typically an account number. In addition, you 
define the fields that appear on agent screens and reports.

Record format The format of the customer records stored in your inbound list varies 
depending on the type of business you do and how you interact with 
your host computer.
If your agents work directly with a host computer, your customer 
records may contain only a single custom field. Agents use the 
information in this field to query the host computer for an account 
record.
In a standalone system, the format of the customer records may be 
similar to your outbound calling list. However, many of the fields are 
empty because agents use these fields to collect information during 
calling.

Note
You must create an inbound application before you can define an 
inbound list.

Define input fields After you create an inbound application, you define the inbound list 
format.

Data types Use the following data types:
• Text
• Date
• Money
• Numeric
• Phone
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• Time
If you select Phone, Administration Manager automatically sets the 
field name to PHONE1, PHONE2, and so on. If a field contains both 
alpha and numeric characters, select Text as the data type. You may 
also select Text for all numeric data if it is not used in any calculation.

Plan When you need to create an inbound list definition, consider the 
following questions before using Administration Manager:
• Will agents work directly on your host computer (interactive 

system)?
• If the system is interactive, what is the query field?
• Will you use the Avaya PDS as a standalone system?
• Which fields do you want to retain for account records?
• What completion codes will agents use?
• Which fields does an agent need to efficiently serve the caller?
• What information do you want in reports?
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............................................................................................................................................................................................................................................................
Create an inbound list

Create an inbound list Use the following procedure to create an inbound list.

...........................................................................................................................................................................

1 Select Application > Inbound List Format.

...........................................................................................................................................................................

2 Select the system and application in the Select Application dialog box 
and then click OK.

...........................................................................................................................................................................

3 Select Input in the Display by Calling List Source area.

...........................................................................................................................................................................

4 Type a field name (no larger than 15 alphanumeric characters) in the 
Field Name box.

...........................................................................................................................................................................

5 Select the field type in the Type box.

...........................................................................................................................................................................

6 Type the maximum number of characters allowed in the Length box.

...........................................................................................................................................................................

7 Type a brief description of the field in the Description box.

...........................................................................................................................................................................

8 Select File > Save.

...........................................................................................................................................................................

9 In the Save dialog box, select In Process or Complete.
If you complete all your changes and want the download definition 
transferred to the system, select Complete. If you are not ready to 
transfer the definition, select In Process.
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............................................................................................................................................................................................................................................................
Overview

Purpose The upload process transfers data stored in inbound and outbound 
calling lists to your host. Use Administration Manager’s upload feature 
to set up the file formats and file transfer details used to transfer files 
from the AvayaTM Predictive Dialing System to the host computer.

Contents This section contains the following topics:
• Upload file definition overview
• Edit upload fields
• Create special formats
• Add field filler information
• Add data translations
• Create the upload file structure
• Complete an FTP upload
• Complete a tape upload
• Specify the upload selection criteria
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Upload file definition overview

Overview Using the upload feature, you provide the Avaya PDS with four sets of 
information.
• You provide information about the layout of the host upload file 

and the field attributes of each record. Typically, you upload some 
or all of the fields included in the calling list.

• You describe the format, block size, and file structure in the 
upload file.

• You define how the data transfer occurs. You can transfer data to 
the host Avaya PDS using either FTP or tape (if your Avaya PDS 
is currently set up to use a host gateway, you can select the host 
gateway transfer method).

• You define which calling list records to upload.
For each calling list that you want to upload, you must include the 
fields the host system needs for its processing. Gather the necessary 
format and file transfer information from your system administrator.

Host Gateway LAN file
transfer

If you use a Host Gateway LAN for file transfer, a radio button will 
already be selected for that option in Administration Manager. Do not 
change this to another option! If you do, you will lose that ability and 
will have to have it reconfigured.
The Host Gateway LAN file transfer option is obsolete with Avaya 
PDS 12.0. If you have an earlier version of the Avaya PDS,  you can 
still use it. But remember, do not change file transfer methods in 
Adminstration Manager or you will lose the ability to transfer files via 
Host Gateway LAN.

Upload file definition Upload on the Application menu tells the Avaya PDS which fields to 
upload and defines the format for each upload file. The Upload dialog 
box consists of four tabs:
• Fields
• Structure
• Method
• Select
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Note
Before you create an upload definition, you must define an application. 
You may also want to define the download and calling lists for this 
application before defining the upload.

Data Types You must choose a data type:
• Text
• Date
• Money
• Numeric
• Phone
• Time
If you select Phone, Administration Manager automatically sets the 
field name to PHONE1, PHONE2, and so on. If a field contains both 
alpha and numeric characters, select Text as the data type. You 
may also select Text for all numeric data if it is not used in any 
calculation.

Duplicate removal In order to remove duplicate records during the upload process, you 
must first understand how the process works. 
During upload or download processing, the Avaya PDS can be 
configured to remove duplicate records. You specify a calling list field 
that is unique to each record, for example, an account number. If, 
during processing, there are two records with the same account 
number, the second record will be marked with an R in the calling list 
STATUSFLAG field. This tells the system not to call the second 
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record, because it contains the same account number as another record 
in the calling list.
Fill in the following text boxes if you want to remove duplicate records 
during the upload process:
• Unique ID
• Extraction ID
• Extraction Value

Unique ID
The Unique ID text box requires an entry that corresponds to a unique 
field on your calling list. Select a calling list field from the drop down 
list that is unique to the record, for example, an account number 
(ACCTNUM). The entry in the Unique ID text box is how the Avaya 
PDS will identify duplicate records. Once duplicate records are found, 
an R is placed in the STATUSFLAG field of the duplicate record.

Extraction ID and Extraction Value
The Extraction ID text box and the Extraction Value text box work 
together to remove duplicates from a calling list once they have been 
flagged as duplicate records.
Choose the STATUSFLAG field from the drop down of the Extraction 
ID text box. Remember, if there is an R in the STATUSFLAG field, the 
record was marked as a duplicate record.
The Extraction Value is the value in relation to the field that you chose 
in the Extraction ID text box. For example, if you want a list of all valid 
records (no duplicates) then you want a list of all records without an R 
in the STATUSFLAG field. If the Extraction Value = ~R (not R), 
records without an R in the STATUSFLAG field are temporarily saved 
to another location. A new list is created, containing only records 
without STATUSFLAG R. This new list overwrites the original list, 
giving you a list without duplicates.
The following is an example of how to fill-in the three text boxes to 
remove duplicate records from a calling list during upload activities: 
• Unique ID = ACCTNUM
• Extraction ID = STATUSFLAG
• Extraction Value = ~R
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Note
You cannot add entries to one field without adding entries into the 
other. This will cause corruption to your calling list. Either fill in all 
fields or leave all fields blank. 

Plan When you need a new upload definition, consider the following 
questions before using Administration Manager:
• What is the format of the calling list information?
• What format does the host require to read data?
• Which fields from the calling list do you want to upload?
• Is there any special formatting you want to apply during the 

upload process?
• What is the file and record structure of the upload file?
• What upload method do you use?
• Which records do you want to upload to the host?
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Edit upload fields

Edit upload fields Use the following procedure to edit upload fields.

...........................................................................................................................................................................

1 Select Application > Upload.

...........................................................................................................................................................................

2 Select the system in the Upload - Select Application dialog box.

...........................................................................................................................................................................

3 Select the application and then click OK.

...........................................................................................................................................................................

4 Type the field name (up to 15 alphanumeric characters) of the first field 
you want to upload In the Field name box.
If you want to upload all or most of the fields from the calling list, select 
Edit > Power Load. Administration Manager copies all field 
definitions but not special formatting from the calling list to the Upload 
Fields tab.

...........................................................................................................................................................................

5 Select the type of information that appears in this field in the Type box.

...........................................................................................................................................................................

6 Type the number of characters in the field In the Length box.
You enter the exact number of characters to upload in the length box. 
The Avaya PDS formats data based on special formats but only sends 
the number of characters specified.

...........................................................................................................................................................................

7 Select the Same Start check box if this field uses the same data as the 
previous field.
This option uses data from the previous field to populate the current 
field. For example, if the previous field contains both the area code and 
phone number, type 3 in the Length box and select the Same Start check 
box to place the area code in a separate field when it is uploaded.

...........................................................................................................................................................................

8 Type a description of the field.
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...........................................................................................................................................................................

9 Click the Special button to define special formatting for this field.

...........................................................................................................................................................................

10 Repeat steps 4 through 9 for each field in the upload file.

...........................................................................................................................................................................

11 Select File > Save.

...........................................................................................................................................................................

12 In the Save dialog box, select In Process or Complete.
If you complete all your changes and want the upload definition 
transferred to the Avaya PDS, select Complete. If you are not ready to 
transfer the definition, select In Process.
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............................................................................................................................................................................................................................................................
Create special formats

Create special formats Use the following procedure to create special formats.

...........................................................................................................................................................................

1 Select Application > Upload.

...........................................................................................................................................................................

2 Select the Upload Fields tab.

...........................................................................................................................................................................

3 Select the field you want and click the Special button. The Special 
Format dialog box appears.

...........................................................................................................................................................................

4 Select or type the format of the data in the host record in the Host 
format box.

...........................................................................................................................................................................

5 Select or type the format that you want the data displayed on the system 
in the Dialer format box and then click OK.
1 0 - 1 1 4



Upload data
............................................................................................................................................................................................................................................................

............................................................................................................................................................................................................................................................
Add field filler information

Add field filler information Use the following procedure to add field filler information.

...........................................................................................................................................................................

1 Select the field you want on the Upload Fields tab and then click 
Special.

...........................................................................................................................................................................

2 Select the Insert Data tab in the Special Format dialog box.

...........................................................................................................................................................................

3 Type the information you want to force into the selected field in Fill 
info. 
The system inserts into the field exactly what you type. For example, if 
you want to fill a five-character field with asterisks, type five asterisks.

...........................................................................................................................................................................

4 Click OK.
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Add data translations

Add data translations Use the following procedure to add data translations.

...........................................................................................................................................................................

1 Select the field you want and click Special on the Upload Fields tab.

...........................................................................................................................................................................

2 Select the Translate tab in the Special Format dialog box and then 
click Append.

...........................................................................................................................................................................

3 Type the data as it appears in the host field in the Host data box.
Leave the field blank to represent a null field. Press the spacebar to enter 
a space character.

...........................................................................................................................................................................

4 Type the data you want in the uploaded field in the Dialer data box.
Leave the field blank to represent a null field. Press the spacebar to enter 
a space character.

...........................................................................................................................................................................

5 Repeat steps 3 through 5 for each data pair you want to define.

...........................................................................................................................................................................

6 Type the default value you want to use when the host field contains a 
value that doesn’t appear in the Host data list in the Dialer default field. 
This is an optional entry. The calling list uses this value if no match is 
found between the host field value and values in the Host data list. If you 
leave this field blank, the calling list field is left empty when no match 
is found.

...........................................................................................................................................................................

7 Click OK.
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Create the upload file structure

Create the upload file
structure

Use the following procedure to create the upload file structure.

...........................................................................................................................................................................

1 Select the Structure tab in the Upload dialog box.

...........................................................................................................................................................................

2 Type the size of one host record if necessary, in the Record Size box. 
By default, Administration Manager displays the ending position for the 
last field defined on the Fields tab. This field must contain an entry.

...........................................................................................................................................................................

3 Type the size of the buffer in which the records are stored in the Block 
Size box.

...........................................................................................................................................................................

4 Type the number of blocks to read in the Blocks Read box. 
Administration Manager displays a default value of 1. The 
recommended setting is 10. Blocks Read multiplied by Block Size (the 
number of bytes that the system reads before processing the data) must 
not exceed 32,000. If Blocks Read is too high, the system converts no 
records and displays no error statements. This field must contain an 
entry.
Administration Manager does not automatically update the Structure tab 
if you change the record length on the Fields tab. You must type the new 
Record Size, Block Size, and Blocks Read settings to reflect the new 
record length.

...........................................................................................................................................................................

5 Type the number of bytes in the host file to skip before beginning data 
conversion and writing in the Skip Records box.

...........................................................................................................................................................................

6 Type the number of bytes to convert and write in the Read Bytes box.
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...........................................................................................................................................................................

7 Type a two-digit year number in the Switch Year box. Complete this 
field if your system is year 2000 compliant and your Administration 
Manager system supports the Switch Year feature.

...........................................................................................................................................................................

8 Select the value (null or space) to place in every blank position for all 
fields in each record in the Terminator list.

...........................................................................................................................................................................

9 Select the data type (ASCII or EBCDIC) of the host file in the 
Character Set list. This field must contain an entry.

...........................................................................................................................................................................

10 Select the method to use to handle type case in the Case Conversion 
list.
The default is UPlow (leave case as is). Other options are UPPER 
(convert all characters to uppercase) and lower (convert all characters to 
lowercase).

...........................................................................................................................................................................

11 Select Remove carriage return to remove carriage returns from each 
record.

...........................................................................................................................................................................

12 Select the Remove line feed check box to remove line feeds from each 
record.

...........................................................................................................................................................................

13 Type the name of the custom upload process for your system (optional) 
in the Custom Executable box.

...........................................................................................................................................................................

14 Select File > Save.

In the Save dialog box, select In Process or Complete.
If you complete all your changes and want the upload definition 
transferred to the Avaya PDS, select Complete. If you are not ready to 
transfer the definition, select In Process.
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............................................................................................................................................................................................................................................................
Complete an FTP upload

Complete an FTP upload Use the following procedure to complete an FTP upload.

...........................................................................................................................................................................

1 Select Application > Upload.

...........................................................................................................................................................................

2 Select the system in the Upload - Select Application dialog box.

...........................................................................................................................................................................

3 Select the application and click OK.

...........................................................................................................................................................................

4 Select the Method tab, and then select FTP.

...........................................................................................................................................................................

5 In the Server Name box, type the system name for the host computer.

...........................................................................................................................................................................

6 In the Logon box, type the logon user name for the host computer.

...........................................................................................................................................................................

7 In the Password box, type the logon password for the host computer. 
If you complete all your changes and want the upload definition 
transferred to the Avaya PDS, select Complete. If you are not ready to 
transfer the definition, select In Process.

...........................................................................................................................................................................

8 In the Host File box, type the path and file name of the file on the host 
system.

...........................................................................................................................................................................

9 Select File > Save.

...........................................................................................................................................................................

10 In the Save dialog box, select In Process or Complete.
If you complete all your changes and want the definition transferred to 
the Avaya PDS, select Complete. If you are not ready to transfer the 
definition, select In Process.
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Complete a tape upload

Complete a tape upload If you use 9-track tape to transfer information between the Avaya PDS 
and the host computer, use the following procedure to complete a tape 
upload.

...........................................................................................................................................................................

1 Select Application > Upload.

...........................................................................................................................................................................

2 Select the system in the Upload - Select Application dialog box.

...........................................................................................................................................................................

3 Select the application and then click OK.

...........................................................................................................................................................................

4 Select the Method tab and then select Tape.

...........................................................................................................................................................................

5 Select the tape density in the Density box.
/dev/rmt/2hsn for high density tape
/dev/rmt/2msn for low density tape

...........................................................................................................................................................................

6 Select the type of tape header (IBM or none) in the Label box.
If you select IBM, the Avaya PDS skips the header information at the 
beginning of the file.

...........................................................................................................................................................................

7 Select File > Save.

...........................................................................................................................................................................

8 In the Save dialog box, select In Process or Complete.
If you complete all your changes and want the definition transferred to 
the Avaya PDS, select Complete. If you are not ready to transfer the 
definition, select In Process.
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Specify the upload selection criteria

Specify the upload
selection criteria

Use the following procedure to specify the upload selection criteria.

...........................................................................................................................................................................

1 Select the Select tab in the Upload dialog box.

...........................................................................................................................................................................

2 Select the field to use to select records to upload.

...........................................................................................................................................................................

3 Type a field value and then click Append.

...........................................................................................................................................................................

4 Repeat steps 3 and 4 for each field value.

...........................................................................................................................................................................

5 Select File > Save.

...........................................................................................................................................................................

6 In the Save dialog box, select In Process or Complete.
If you complete all your changes and want the upload definition 
transferred to the Avaya PDS, select Complete. If you are not ready to 
transfer the definition, select In Process.
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11 Transfers and schedules
............................................................................................................................................................................................................................................................

............................................................................................................................................................................................................................................................
Overview

Purpose Transfer processing allows you to set up and modify scheduled events 
that you define, such as uploads, downloads, and job related tasks. You 
can also view processes that the AvayaTM Predictive Dialing System 
(PDS) schedules and executes.

Contents This section contains the following topics:
• Transfer and schedules overview
• Commands and parameters
• Create file transfer routines
• View event schedules
• Schedule a dialer event
• Dialer events schedule examples
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Transfer and schedules overview

Transfers overview Use the File Transfer Setup dialog box to define file transfer processing 
for the downloads and uploads you have defined. Typically, a file 
transfer routine is made up of one or more data transfers of the same 
kind. For example, you might define one transfer routine for downloads 
and another transfer routine for uploads. You must define a file transfer 
routine before you can schedule it, even if the transfer routine contains 
only one download or upload.

Schedules overview You can define scheduled events, such as transferring files, starting 
jobs, and selecting records. You add and modify your scheduled events 
in the Dialer Event Schedules dialog box. Administration Manager 
does not allow you to edit Special Program events. Instead, delete 
Special Program events that no longer meet your needs and then define 
one or more new events.
• Schedule downloads to occur Monday, Wednesday, and Friday at 

5 AM and end by 8 AM. (Use File Transfer Setup to define the 
end time.)

• Schedule record selections to run Tuesdays and Thursdays at 9 
AM.

• Schedule jobs to start Tuesday and Thursday at 10 AM.
• Schedule a report to run daily at 6 PM.
The Dialer Event Schedules dialog box displays file transfer and dialer 
processes. You can view all scheduled processes or only the processes 
you have defined and sort the display by the time the process is 
scheduled to occur or alphabetically by process. You can also view and 
print the Dialer Event Schedules report. 
For each scheduled process, Administration Manager displays the 
following information.

Start time The time of day (in minutes and hours) that the 
event is scheduled to start. An asterisk (*) in the 
hour field indicates that the process runs every hour.

Day The day that the event is schedules to run. An 
asterisk (*) indicates that the process runs every day 
or every day of the week displayed in the Weekday 
field.
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Month The month that the event is scheduled to run. An 
asterisk (*) indicates that the process runs every 
month on the days selected in the Day or Weekday 
fields.

Weekday The day(s) of the week the process is scheduled to 
run. Days are numbered 0 through 6 representing 
Sunday through Saturday. An asterisk (*) indicates 
that the process runs every day of the month 
selected in the Day field.

Command The binary file or script name for the process.

Parameter Any parameters associated with the process.

End time For file transfers, the time of day that the Avaya 
PDS stops attempting the transfer.
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Commands and parameters

Overview For each event that you schedule, you select a command and any 
required parameters. Parameters provide additional information the 
Avaya PDS uses to run the command. The parameters available depend 
on the selected command.

The following list provides tips for setting up command parameters:
• When typing command parameters, include the directory path for 

each command, and include all appropriate flags and arguments.
• After Administration Manager synchs the event schedules with 

the Avaya PDS, the command parameters may appear to be 
different. The schedule parameters still meet Avaya PDS 
requirements. No changes are necessary.

• When you change any parameter in a schedule, Administration 
Manager clears the other parameter fields. Be sure to reselect or 
retype all necessary parameters.

• Typically, you select Parameter 3 (2>/dev/null 1>/dev/null) to 
redirect messages produced by the selected command to a null 
device instead of the Avaya PDS administrator console.

Command Parameters

File transfer Select a file transfer routine you created 
using the File Transfer Setup option on the 
System menu.

Start job Select a job name.

Run report Select a calling list name and report name.

Run selection Select a calling list name and the record 
selection name.

Run special program Select or type the special program name. 
Include the directory path (/usr/vl/custom) 
with the program name. You can type 
additional command information in the 
same parameter field as the program name.
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Note
If you schedule record selections and jobs, you should still verify that 
your download was successfully received.
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Create file transfer routines

Create file transfer routines Use the following procedure to create file transfer routines.

...........................................................................................................................................................................

1 Select System > File Transfer Setup.

...........................................................................................................................................................................

2 Select the system from the Select System dialog box and then click 
New.

...........................................................................................................................................................................

3 Type a name and description for the file transfer routine and then click 
OK.

...........................................................................................................................................................................

4 Type the time that the Avaya PDS will stop attempting a transfer in the 
End time box. This is a required entry. Use the 24-hour format (for 
example, 19:30 represents 7:30 PM).

...........................................................................................................................................................................

5 Select a process to run (download or upload) in the Transfer to box.

...........................................................................................................................................................................

6 Select the calling list to use in the Calling list name box.

...........................................................................................................................................................................

7 Type the number of minutes and seconds to wait between each calling 
list transfer in the Delay box.

...........................................................................................................................................................................

8 Select the Retry check box if you want to repeat the process if an 
attempt fails. If you select this option, attempts are repeated until the end 
time.

...........................................................................................................................................................................

9 Select Edit > Append Row to add another transfer to the routine. (If you 
select Retry, Administration Manager automatically adds a new row to 
the transfer routine.)
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...........................................................................................................................................................................

10 Repeat steps 6 through 10 for each additional transfer.

...........................................................................................................................................................................

11 Select File > Save.

...........................................................................................................................................................................

12 From the Save dialog box, select In Process or Complete.
If you complete all your changes and want the file transfer setup 
definition transferred to the Avaya PDS, select Complete. If you are not 
ready to transfer the definition, select In Process.
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View event schedules

View event schedules Use the following procedure to view event schedules.

...........................................................................................................................................................................

1 Select System > Dialer Event Schedules.

...........................................................................................................................................................................

2 Select the system from the Select System dialog box and then click OK.

...........................................................................................................................................................................

3 Select User entries or All entries.

...........................................................................................................................................................................

4 Select Sort by time or Sort by process.

...........................................................................................................................................................................

5 Select File > Close when you finish.
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Schedule a dialer event

Schedule a dialer event Use the following procedure to schedule a dialer event.

...........................................................................................................................................................................

1 Select System > Dialer Event Schedules.

...........................................................................................................................................................................

2 Select the system from the Select System dialog box and then click OK.

...........................................................................................................................................................................

3 Select User entries.

...........................................................................................................................................................................

4 Select Edit > Append Row. The Dialer Event Schedules dialog box 
appears.

...........................................................................................................................................................................

5 Select the process you want to schedule in the Command list.

...........................................................................................................................................................................

6 Select or type any parameters associated with this process in the 
Parameter boxes. For example, if you selected Transfer File in the 
Command box, select a file transfer routine (defined using the File 
Transfer Setup feature) in the Parameters box.

...........................................................................................................................................................................

7 In the Start Time boxes, select the hour and minutes when you want the 
process to start. Remember to use a 24-hour clock.

...........................................................................................................................................................................

8 In the Day box, select the day you want the process to run. 

...........................................................................................................................................................................

9 In the Weekday box, select the day of the week you want the process to 
run.

...........................................................................................................................................................................

10 In the Month box, select the month you want the process to run.
You can select multiple months.
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...........................................................................................................................................................................

11 In the Comments box, type any additional information about the 
process and then click OK. You can modify existing user-defined event 
schedules. In the Dialer Event Schedules dialog box, double-click the 
schedule you want to modify.
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Dialer events schedule examples

Dialer events schedule
examples

The following table provides examples of dialer event schedules and 
describes how the Avaya PDS interprets the settings.

Minute Hour Day Month Weekday Result

30 * * * * The command 
runs every hour 
of every day at 
30 minutes past 
the hour.

30 00 * * * The command 
runs every day at 
12:30 AM.

30 04 * * 1 The command 
runs at 4:30 AM 
every Monday.

07 00 15, 30 4, 6, 8, 10 * The command 
runs at 7:00 AM 
on the 15th and 
30th of April, 
June, August, 
and October.

15, 30 11, 
17

* * 1, 3, 5 The command 
runs at 11:15 
AM, 11:30 AM, 
5:15 PM, and 
5:30 PM every 
Monday, 
Wednesday, and 
Friday.
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00 06 * * 1, 2, 3, 4, 
5

The command 
runs at 6:00 AM 
every Monday 
through Friday. 
This is a typical 
schedule for 
downloads.

00 21 * * 1, 2, 3, 4, 
6

The command 
runs at 9:00 PM 
every Monday 
through 
Thursday and 
Saturday. This is 
a typical 
schedule for 
uploads.

Minute Hour Day Month Weekday Result
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Overview

Purpose Administration Manager provides a set of reports that you can view or 
print. The reports provide details on the Administration Manager 
settings for the selected AvayaTM Predictive Dialing System (PDS). 
Administration Manager also provides two reports that provide details 
on the data install process.

Contents This section contains the following topics:
• Administration Manager reports
• Reports
• Report legend
• Generate an Administration Manager report
• Generate an Out of Synch report
• Preview an Out of Synch report
• Print an Out of Synch report
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Administration Manager reports

Administration Manager
reports

Use the report information to review and verify your Administration 
Manager settings before you use Install Data to transfer them to the 
Avaya PDS. The reports also provide a hard copy archive of your 
settings.
Administration Manager provides the following reports.

Report title Description

Agent Keys Report For each agent key, lists the control 
sequence, key or key sequence, action, call 
result or screen number, and automated 
message assignment name.

Calling List Features 
Report

Lists call tracking definitions, including 
attempt type, number of phone fields, 
number of attempts, and completion codes 
to track.

Calling List Format 
Report

Lists the settings for each calling list field, 
including the name, type, source, length, 
and description.

Calling List 
Processing Order 
Report

For each calling list process defined, lists 
the sequence number, description, and any 
parameters.

Completion Code 
Report

For each completion code, lists the number, 
call result, description, recall setting, and 
code type.

Configuration Report Lists information from the System Setup 
Configuration tab, including the 
configuration fields and values entered.

Dialer Event 
Schedules Report

Lists the scheduled time, command name, 
parameters, and end time for each 
scheduled event.

Download Format 
Report

For each download field, lists the name, 
length, type, start position, end position, 
and any special formatting that has been 
defined.
1 2 - 1 3 6



Reports
............................................................................................................................................................................................................................................................

Download Processing 
Report

Lists the file structure and transfer method 
settings for the selected calling list.

Late List Field Report Lists the calling list name, field names, and 
descriptions that have been identified for 
updating.

Late List Value Report Lists the calling list name, completion 
codes, and descriptions that have been 
selected for updating.

Message Text Report For each message, lists the message 
number, file name, music or voice (male or 
female), message text, and message type 
(inbound, outbound, automated).

Message Assignment 
Automated Message 
Report

For each queue, lists the queue name, wait 
queue action assigned, and message 
content.

Message Assignment 
Inbound Wait Queue 
Report

For each inbound wait queue, lists the 
queue name, wait queue actions assigned to 
the queue, and message content.

Message Assignment 
Outbound Wait Queue 
Report

For each outbound wait queue, lists the 
queue name, wait queue actions assigned to 
the queue, and message content.

Network Report Lists information from the System Setup 
Network tab, including the host TCP/IP 
address, alias, description, and modem 
server.

System Basic 
Information Report

Lists information from the System Setup 
Customer tab, including mailing and 
shipping addresses, and customer contacts.

System Features 
Report

Lists information from the System Setup 
Features tab, including the features and 
products installed on this system.

System Summary 
Report

Provides a summary of all System Setup 
information.

Report title Description
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For Administration Manager reports, you can select only one of the 
following completion statuses.
• In Process: The file definition is not complete.
• Complete: The file definition is complete.
• Pending: Administration Manager has transferred the file 

definition to the Avaya PDS. The next time the system reboots and 
synchronizes with Administration Manager, Administration 
Manager changes the status to Live

• Live: The files that have been transferred from Administration 
Manager to the Avaya PDS.

Upload Format Report For each upload field, lists the name, 
length, type, start position, end position, 
and any special formatting that has been 
defined.

Upload Processing 
Report

Lists the file structure and transfer method 
settings for the selected calling list.

Report title Description
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Reports

Data install reports Administration Manager provides two reports. The Out of Synch report 
lists the Avaya PDS configuration files that have been modified since 
the previous install data process. The Install report contains the results 
from the Avaya PDS installation process, which occurred during the 
most recent Avaya PDS reboot. The installation process activates 
Administration Manager files on the Avaya PDS.
The following sections provide more information about each report 
including a report legend which describes the files listed in the Out of 
Synch and Install reports.

Out of Synch report The Out of Synch report identifies files on the Avaya PDS that are no 
longer in synch with the files on Administration Manager. When 
Administration Manager runs the Install Data command, it first verifies 
that all files on the Avaya PDS are still in synch. If Administration 
Manager determines that a file is out of synch, it imports the file from 
the Avaya PDS, displays a warning, and writes the information to the 
Out of Synch report. The Out of Synch report contains the following 
information.

Report information Description

Date Displays the date, in MM/DD/YY format, 
that the install data occurred.

Time Displays the time, in HH:MM:SS format, 
that the install data occurred.

System ID Displays the Avaya PDS identification 
number

File name Displays the name of the Avaya PDS file 
that is out of synch. See Report legend for 
descriptions of the files listed in the Out of 
Synch report.

Imported Indicates whether Administration Manager 
imported the Avaya PDS file and saved it 
with a Live status.
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Install report The Install report indicates whether or not the Avaya PDS successfully 
installed the exported Administration Manager files. The installation 
process takes place when the Avaya PDS reboots.
The Install report contains the following information.

Report information Description

System ID Displays the Avaya PDS identification 
number.

Action/Error and Code Displays the Administration Manager 
Install Data batch number that the Avaya 
PDS processed. For each file in the batch, 
the report displays an action, such as 
FILEINSTALL or EXECPROG, or 
indicates an error on the first line. On the 
second line, the report displays an Avaya 
PDS message or error code number for the 
result of the action.

Message and Command If the Action value is a batch number, the 
report displays the date (YY/MM/DD 
format) and time (HH.MM.SS format) 
that the Avaya PDS started the installation 
process. For each file in the batch, the 
report displays the result of the command 
that the Avaya PDS attempted to process. 
On the next line, the report displays the 
command, which consists of the action, a 
directory location, and a file name.
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Report legend

Report legend This report legend describes the files listed in Administration 
Manager’s Out of Synch and Install reports. The files are displayed in 
alphabetical order according to file extension.
The Administration Manager feature that you use to define the file’s 
settings follows each file description. The following information also 
appears at the end of each report.

Crontab
Lists the processes that are scheduled to run automatically on the dialer. 
For each process, the crontab contains settings for the time (minute 
and hour), day(s) of the week, month(s), and day(s) of the month. 
When a time listed in the crontab matches the dialer system time, the 
dialer starts the specified process.
(System > Dialer Event Schedules)

PUlist*.cfg
Contains information the Avaya PDS uses for due diligence 
(postupdate) processing.
(Application > Calling list 
Features tab)

compcode.cfg
Lists all of the call completion codes (system and agent) for the dialer.
(System > Completion Codes)

voicemsg.cfg
Lists the digitized voice messages installed on the dialer.
(System > Message Text)

*.conf
Contains information about the host data file and its format, including 
the record size and character set.
(Application > Download and Upload 
Fields tab including special formats)
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*.dict
Defines the record layout of the host data file. For each field in a 
record, a dictionary (*.dict) file contains the field start position, field 
length, data type, host format, dialer format, and other special 
formatting instructions.
(Application > Download
Fields tab including special formats)

*.dnld
Contains download file transfer information, such as the selected 
download transfer method and host login name and password.
(Application > Download
Structure and Method tabs)

*.fdict
Contains the record format information used to convert host data into a 
calling list.
For each field in a record, a file dictionary (*.fdict) defines the field 
name, field length, data type, and description. File dictionaries contain 
definitions for host fields, customer-added fields, and dialer-added 
fields.
(Application > Calling List
Fields tab)

script.hlp
Contains information about the telephony.spt file, such as message 
assignment labels (queue names) and wait queue message names and 
text. The script.hlp file is part of the Avaya PDS character-based help 
system.
(System > Message Assignments)

*.ky
Contains agent key definitions that identify, for example, key 
combinations and actions such as release line or transfer call.
(System > Agent Keys)

*.prep
Contains the calling list preparation information, for example, to 
remove duplicate records, index the calling list, and calculate the 
number of consecutive days a record has been sent to the dialer.
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(Application > Calling List
Prepare, Update, Custom, and Ordering tabs)

*.rd_tape
Contains file transfer information for downloads, such as the dictionary 
(.dict) and configuration (.conf) file names and whether to append 
downloaded data to an existing list.
(Application > Download
Structure and Method tabs)

telephny.spt
Contains call processing information, including message assignments, 
which tell the dialer how to handle calls. The telephny.spt file must not 
exceed 1500 lines.
(System > Message Assignments)

agentkey.tbl
Lists the agent keys (*.ky) files set up for the Avaya PDS. Campaign 
Director also references the agentkey.tbl file.
(System > Agent Keys)

calllist.tbl
Lists the calling lists currently on Administration Manager and the 
Avaya PDS. Campaign Director also references the calllist.tbl file.
(Application > Application Definition and Calling List)

telephny.tbl
Lists the wait queue labels (message assignment names) currently in 
the telephny.spt file. Campaign Director also references the telephny.tbl 
file.
(System > Completion Codes)

code.tsub
List the completion codes and descriptions that the Avaya PDS uses 
when it generates calling list reports.
(System > Completion Codes)

*.upld
Contains upload file transfer information, such as the selected upload 
transfer method and host login name and password.
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(Application > Upload
Structure and Method tabs)

*.wt_tape
Contains file transfer information for uploads, such as the dictionary 
(.dict) and configuration (.conf) file names, upload selection criteria, 
and the calling list name.
(Application > Upload
Structure, Method, and Select tabs)

*.xfr
Contains file transfer routine settings, such as the transfer end time, 
transfer type (download or upload), calling list name, delay time, and 
whether to retry an unsuccessful transfer.
(System > File Transfer Setup)
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Generate an Administration Manager report

Generate an Administration
Manager report

Use the following procedure to select the Administration Manager 
report.

...........................................................................................................................................................................

1 Select Administration > Administration Manager Reports.

...........................................................................................................................................................................

2 Select the system for which you want to generate Administration 
Manager reports.

...........................................................................................................................................................................

3 Select the report destination.

...........................................................................................................................................................................

4 Select the completion status you want to include in the reports.

...........................................................................................................................................................................

5 From the Report Master List, select the report you want to generate, 
and then click >.

To select multiple reports, press Ctrl key and click the field names. To 
select all reports, click >>. To remove a report from the Selected Report 
List, click <. To remove all reports from the list, click <<.

...........................................................................................................................................................................

6 Select Edit > Run System Reports.

Administration Manager generates the selected reports. If you selected 
multiple reports for display, Administration Manager displays each 
report consecutively. You can preview the printed report or print the 
report.

...........................................................................................................................................................................

7 Click Cancel to display the next report.
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Generate an Out of Synch report

Generate an Out of Synch
report

Use the following procedure to generate an Out of Synch report.

...........................................................................................................................................................................

1 Select Administration > Out of Synch Report. Administration 
Manager automatically displays the report.
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Preview an Out of Synch report

Preview an Out of Synch
report

Use the following procedure to preview an Out of Synch report.

...........................................................................................................................................................................

1 In the Out of Synch Report dialog box, click Preview. Use the Zoom and 
Show Ruler options to change the preview.
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Print an Out of Synch report

Print an Out of Synch
report

Use the following procedure to print an Out of Synch report.

...........................................................................................................................................................................

1 In the Out of Synch Report dialog box, click Print.
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Glossary

Action
Actions are tasks such as managing calling list functions, running scripts, and 
installing or removing files.

Active job
A job that the Avaya PDS is currently using to call customers. A job becomes 
active when the system supervisor starts it. The job stays active as long as it’s 
running.

Agent
A person who talks with customers and updates customer records.

Agent key
The function keys at an agent workstation. The keys are programmed to perform 
specific tasks. They are also called pf keys.

Agent release code
The completion codes agents assign to a customer record to indicate a call’s 
outcome. Examples include Promise to Pay and Left Message.

Agent screen
The dialog box on an agent’s monitor where the Avaya PDS displays customer 
records and prompts.

Allow retries (Same as Allow Recalls)
A parameter that allows the Avaya PDS to schedule calls to be recalled 
automatically. Typical completion codes that use this parameter are BUSY and 
NOANSWER.

American Standard Code for Information Interchange (ASCII)
A binary code for text as well as communications and printer control. By 
standardizing the values used for these characters, ASCII enables computers to 
exchange information. Also called a text file, a text-only file, or an ASCII text file. 
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A document file in the ASCII format contains punctuation but no formatting.

Answer script
A wait queue setting that determines the answer script label to use for inbound 
calling. This label tells the Avaya PDS which message a customer hears while 
waiting for an agent or after business hours.

Application
In Administration Manager, an application is an association of calling lists and 
download and upload file definitions.

AvayaTM Predictive Dialing System (PDS)
The hardware and software that conducts calling activities. Hardware components 
can include a system cabinet, printers, supervisor and agent workstations, and an 
administrator console. The system software contains the settings that conduct and 
track calling activities.

Busy
A system completion code indicating that the call reached a busy signal. Often 
displayed as BUSY.

Calling activity
The activities that the Avaya PDS and agents perform during a job. The system 
calling activities include processing the calling lists, running jobs, calling 
customers, receiving customer calls, monitoring calls between agents and 
customers, recording call results, and generating reports on agent and job statistics. 
Agent calling activities include talking to customers and updating customer 
records.

Calling list
A modified version of the customer records. The Avaya PDS adds fields that allow 
it to process the customer records and track calling results. The system reformats 
the records to make them easier to read and display.

Calling result
A parameter that determines which customer records to call based on the results of 
previous calls.

Calling script
An outbound job parameter that determines the calling script label for wait queue 
messages. This label tells the Avaya PDS which wait queue message a customer 
hears while waiting for an agent.
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Campaign
A strategy designed to achieve call center goals. A campaign includes one or more 
jobs. Each job definition accomplishes specific goals.

Analyst
A business information access, analysis, and reporting tool for a client/server 
environment. Analyst allows you to produce both standard and exception reports 
on various aspects of call center performance.

Campaign Director
The program group that can include the Monitor, Analyst, and Editor.

Editor
The Campaign Director software that supervisors use to create or edit phone 
strategies, record selections, and jobs.

Monitor
The Campaign Director software that supervisors use to identify system resource 
allocations, set alarms, set and observe job goals, and display other aspects of job 
productivity.

Completion
In Administration Manager, the completion status of a file. Administration 
Manager automatically selects Complete files for transfer to the Avaya PDS.

Completion code
A code that represents the result of the last call the Avaya PDS made for a record. 
The system records the result of each call that is not passed to an agent, such as 
Busy and No Answer. An agent uses function keys on the computer keyboard to 
record the call result.

CTI
Computer Telephony Interface. A generic term for the interface that allows a 
telephony switch to perform data communication with a computer.

Customer
A person the Avaya PDS calls during a job or a person who calls the Avaya PDS. 
A customer typically talks to an agent but may also hear messages.

Data file
A collection of data records that consists of customer information, job statistics, 
and agent statistics.
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Data process
A parameter that identifies the label name for the set of instructions the Avaya PDS 
uses to process a record before and after handling an outbound or inbound call.

Digitize
To convert an analog file to a digital file. This process is used to convert voice 
messages to digital files for use on the Avaya PDS.

Download
The process that transfers a data file from the host computer to the Avaya PDS.

Due Diligence
Also called post-update, number of attempts, and call tracking. Due Diligence is an 
optional feature that the Avaya PDS uses to track the number of call attempts to a 
record. It is particularly helpful to industries that are required to contact a customer 
a minimum number of times before taking an action. For example, some 
institutions cannot refer a past due account to a collection agency until the 
institution has made four unsuccessful attempts to contact the delinquent account.

Duplicate record
A calling list record identified as a duplicate of another record in the calling list. 
Duplicate records are typically identified using a unique field, such as the account 
number or phone number.

File Transfer Protocol (FTP)
A method used to transfer a data file between the Avaya PDS and a host computer.

Function key
Another name for the programmable keys on the keyboard to which you assign 
common tasks. The Avaya PDS documentation sometimes calls these keys agent 
keys or pf keys (programmable function keys).

Headset
The electronic equivalent of the handle of a standard desktop telephone. A headset 
contains a microphone and one or two earphone speakers. The Avaya PDS 
telephone agents and supervisors wear headsets.

Host computer
A computer that stores customer records. A mainframe computer that supplies 
customer telephone numbers and other data to the Avaya PDS for calling jobs. The 
Avaya PDS CPU when used in the digital switch menu system.

Inbound list
A template list that agents use to enter customer data during inbound calling. The 
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Avaya PDS can transfer this information to the host.

In Process
In Administration Manager, the status code that indicates a file is not ready to 
transfer to the Avaya PDS.

Job
A set of instructions that the Avaya PDS uses to place or receive calls and route 
them to agents. The system can run multiple jobs, each with unique settings.

Key file
The setting that identifies the function key set that agents use during a job.

Large Port Voice card (LPVC)
A printed-circuit assembly located in slot 3 in the digital switch subrack that plays 
digitized voice messages during calling jobs.

Live
In Administration Manager, the completion status code used to indicate that a file 
is in use by the Avaya PDS.

Login or Logon
The process of entering a user name and password. When agents log in, the Avaya 
PDS prompts them for a phone extension or key code and agent type.

Login name
A unique name or word that, along with a password, identifies a user to the Avaya 
PDS.

Managed Dialing
An application that offers a call center a non-predictive dialing mode that is 
considerably faster and more efficient than placing calls manually. Managed 
agents can preview the customer record before the system places the call. The agent 
then has the ability to cancel or launch the call.

Message numbers
The number that the Avaya PDS uses to identify a voice message file. The system 
uses these numbers to deliver the messages. The Avaya PDS refers to messages by 
number rather than by file name. Message files are stored on the LPVC in the 
switch, and are loaded into memory when the system needs them. Use only 
message numbers 1 through 247.

Messages (same as voice messages)
Digitized messages that the Avaya PDS plays to customers and agents.
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Message script
A file that tells the system which messages to play, when to play them, and the 
amount of time to pause between messages. Administration Manager message 
scripts are called message assignments.

Message type
Administration Manager classifies messages into four types: automated, inbound 
queue, outbound queue, and universal. Classification is for convenience. You can 
use any message with any job type. Usually, agent key and virtual agent messages 
are classified as automated. Music and generic messages are classified as universal.

No Answer
A system release code indicating that a customer did not answer a call within the 
specified amount of time. Often displayed as NOANSWER.

Outbound (calling) list
A calling list that contains records from the host computer used for outbound 
calling. There is a record for each customer an agent will talk to during a job.

Outbound job
A job that calls customers and connects customers to agents.

PC Analysis
An Avaya PDS feature that allows supervisors to select information to be 
transferred to a PC for analysis and report generation.

Pending
In Administration Manager, the status of a file that was transferred to the Avaya 
PDS. If the transfer was successful, the Avaya PDS will apply the file settings after 
a reboot occurs and after an "Empty" Install Data has been performed.

Preprocessing
The process of checking a data file for duplicate phone numbers and phone 
numbers with an incorrect format. It also determines the time zones for each 
number. In the Avaya PDS, preprocessing takes place after downloading a data file 
and before the Avaya PDS can place calls.

Promise code
A completion code that indicates that an agent contacted the desired audience and 
recorded a commitment from the customer. Codes often identified as promise 
codes include Promise to Pay and Sale.

Prompt
A system message that asks for input or helps a user complete a task.
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Queue
A queue is the place where a call waits until an agent is available. The Avaya PDS 
uses several types of queues including inbound, outbound, virtual agent, and 
transfer queues.

Record
A collection of one or more fields in a calling list. Most calling lists contain one 
record for each customer.

Record selection
All outbound calling activity uses a record selection. The record selection is based 
on time zone settings, completion codes, data value selections, and a phone 
strategy. The selection criteria determines which customers the system calls.

Reject record
A calling list record marked as not callable based on the field data. For example, 
you can reject records with a particular completion code.

Release code
See completion code.

Script file (telphny.spt)
In Administration Manager, the file you create using Message Assignments on the 
System menu. The script file controls the use of recorded messages. When the 
system plays a message, the script file defines the number of messages to play, the 
sequence, and the content.

System release code
The completion code that the system assigns to records for calls not passed to an 
agent. Examples are No Answer or Busy.

Tape drive
The optional half-inch, nine-track, analog magnetic tape drive connected to the 
Avaya PDS CPU. The Avaya PDS site system administrator uses it to download, 
upload, and back up customer data. The DAT tape drive in the Avaya PDS CPU 
that the Avaya PDS site system administrator uses to back up and restore system 
settings.

Time zone
Used to group regions globally. The Avaya PDS bases time zones on area codes 
and exchanges. It uses the time zone settings to determine the local calling time for 
each phone number.
G L O S S A R Y
...........................................................................................................................................................................................................................................................



.........................................................................................................................................................................................................................................................

Uncallable phone number
In the Avaya PDS, a phone number that the system cannot call beause the format 
is incorrect.

Unused completion code
In the Completion Codes dialog box, Administration Manager displays a generic 
code in the Result column (for example, CODE21 or CODE54). Change the names 
in the Results column for the codes you use (for example, NOTIFIED or PTP). You 
can use the Delete Row command to delete codes that you are not using for calling 
operations. Administration Manager displays NOTUSED in the Results column.

Upload
The process of transferring a data file from the Avaya PDS to the host computer.

User name
A name used by an Avaya PDS user, typically the user’s first or last name and 
usually the same as their login name. User names appear on reports and job monitor 
screens.

Virtual Agent
An option that enables the Avaya PDS to automatically deliver messages to both 
live contacts and answering machines, without agent intervention.

Virtual Agent job
An outbound job during which the Avaya PDS manages calling activities without 
agents. A Virtual Agent job places a call, connects the customer or answering 
machine to the system, and plays a recorded message.

Voice and data transfer
A feature that allows an outbound or blend agent to transfer an outbound call and 
its calling list record to an inbound or blend agent on another job.

Wait queue
A holding area where the Avaya PDS places calls when agents are not available.

Wait queue limit
The time that a call remains in the wait queue before the Avaya PDS disconnects it.

Ziptone
A sound that the Avaya PDS transmits to an agent’s headset immediately before 
connecting the agent with a customer. You can define up to four ziptones for 
inbound and outbound calls. Using different tones makes it easier for agents to 
quickly determine whether they are handling an inbound or outbound call.
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9-track tape

uploads, 88, 120

A agent keys

actions, 30
.............................................................................

completion codes for, 18

defining, 28

definition of, 25

planning, 26

predefined, 30

samples, 30

Allow Retries setting, 16

applications

copying, 65

defining, 63

deleting, 66

inbound, 60

outbound, 60

planning, 61

selecting, 64

assignment

message, 43

assignments

create, 47

AU file, 52

Avaya PDS system, setup, 2

C call result codes

see completion codes, 15

calling list

message map, 100

preparation details, 97

Calling List tabs
....................................................................................
Features tab, 93

calling list tabs

custom tab, 99

fields tab, 95

ordering tab, 101

prepare tab, 96

update tab, 98

calling lists

call result tracking, 93

custom fields, 95

custom processing, 99

defining, 90

inbound, 60, ??-106

outbound, 60

preprocessing, 96

processing order, 101

update settings, 98

change message, 42

comparison operators, 57

Complete status code, 6
completion codes

agent, 16

defining, 21

for agent keys, 18

planning, 16

remove, 23

system, 16

Cool Edit, 52
........................................................................................
.............................................................................

copy

an application, 65

custom tab, 99

customer message, 40

D Data Install reports

Out of Sync report, 139

report legend, ??-144

data install reports

install report, 139

out of synch report, 139

report legend, 141

data synchronization, 2, 6, 7
data translations, 82, 116

downloads, 75

database, shared, 7
defining fields

downloads, 72

uploads, 112

definition

download file, 72

delete

an application, 66

Deliver Message, 44

dialer event schedules, 130, 
??-134

examples, 133

digitized messages, 33, 52
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display, 40

download

create file definition, 72

fields tab, 72

file structure, 84, 117

structure tab, 84, 117

download file definition

create, 72

downloading

data translations, 75

file structure, 84, 117

filler information, 81, 
115

planning, 70

special formats, 74

due diligence, 91

duplicate records, 96

duplicates, 109

E edit message, 42

empty data install, 7
equal to, 57

error message, 50

event schedules

examples, 133

viewing, 130

examples

schedule, 133

Export dialog box, 9, 11, 13

export error, message 
assignments, 50

F Features tab, 93

field symbols, 78

fields

merged, 83

fields tab
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calling lists, 95

uploads, 112

file

download definition, 72

file name, 40

file status, 6
file structure

downloads, 84, 117

file transfer routines

defining, 128, 129

setup window, 124

filler information

downloads, 81, 115

Format tab

special formats, 
downloads, 74

FTP

uploads, 86, 119

function keys

see agent keys, 25

G gender

change voice gender, 42

generate reports, 145

greater than, 57

I In Process status code, 6
Inbound Calling List 

window, 104

inbound lists

defining, 106, ??-106

fields, 104

planning, 104

using, 60

insert data tab

special formats, 
downloads, 81, 115

Install Data
........................................................................................
.............................................................................

.............................................................................
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empty, 7
exporting, 9
process, 10

Install data

process overview, 9
install data

pending status, 12

procedure, 11

Intelligent Call Blending, 
104

K keys

see agent keys, 25

L less than, 57

list preparation details, 97

Live status code, 6

M merged fields, 83

message

assignment overview, 43

edit, 42

message assignment

create, 47

message assignments

examples, 45, ??-46

export error, 50

message file names, 37

Message Maps

selecting, 57

message maps

create, 55

overview, 53

select, 58

with calling lists, 100

message numbers, 36

message text, 40
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messages

digitized, 52

file names, 37

numbers, 36

planning, 37

record, 52

text of, 40

value operators, 57

O operators, 57

ordering tab, 101

out of synch conditions, 7
outbound calling lists

call result tracking, 93

custom fields, 95

custom processing, 99

defining, 90

preprocessing, 96

processing order, 101

update settings, 98

using, 60

P Pause, 44

Pending status code, 6, 7
planning

agent keys, 26

completion codes, 16

downloads, 70

inbound lists, 104

message text, 37

messages, 37

post update, 91

preparation details, 97

prepare tab, 96

Producer

overview, 1
Producer report settings, 135
...................................................................................
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Producer reports, 136

generate, 145

R record voice, 52

recording messages, 52

rejected records, 96

remove completion codes, 23

reports

descriptions, 136-138

generating, 145

install report, 139

Out of Sync report, 139

out of synch report, 139

Producer, 136

report legend, 141, 
??-144

result codes

see completion codes, 15

row, 40, 42

S scheduled events

examples, 133

viewing, 130

script file, 50

maximum lines, 50

scripts, 43

create, 47

setup, Avaya PDS system, 2
shared database, 7
sort, 40

source fields, 36

speak, 52

special field formatting

defining, downloads, 74

examples, 79

symbols, downloads, 78

special formats
........................................................................................
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data translations, 82, 116

data translations, 
downloads, 75

defining, downloads, 74

defining, uploads, 112

fields, downloads, 74

filler information, 
downloads, 81, 115

merged fields, 83

special formatting

symbols, 78

Start Looping, 45

status codes, 6
structure tab

downloads, 84, 117

switch year, 75, 78, 79, 85, 
118

symbols

special formatting, 78

synchronize data, 2, 6, 7
system codes, 16

system setup, 2

T telephny.spt, 50

telephony script, 49

text of messages

typed out, 40

transfer methods

FTP, uploads, 86, 119

tape, uploads, 88, 120

transfer processing, 128, 129

Translate tab

special formats, 
downloads, 75

translations, 82, 116

type, 40

change type, 42
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U update tab, 98

upload

fields tab, 112

select tab, 121

upload transfer methods

FTP, 86, 119

tape, 88, 120

uploading

fields, 112

user codes, 16

V value comparison operators, 
57

voice, 52

Voice Response, 45

W wait queues

assigning messages, 47

word-for-word message text, 
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Y year, 75, 79
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